Ask Your Question
0

rostime module not found

asked 2012-07-09 08:22:43 -0600

shuo gravatar image

updated 2012-07-09 09:52:35 -0600

joq gravatar image

When I ran rosbridge, it gives me:

ros@ubuntu:~$ rosrun rosbridge rosbridge.py
Traceback (most recent call last):
  File "/opt/ros/fuerte/stacks/brown_remotelab/rosbridge/bin/rosbridge.py", line 2, in <module>
    from ROSProxy import ROSProxy
  File "/opt/ros/fuerte/stacks/brown_remotelab/rosbridge/bin/ROSProxy/__init__.py", line 1, in <module>
    from ROSProxy import ROSProxy
  File "/opt/ros/fuerte/stacks/brown_remotelab/rosbridge/bin/ROSProxy/ROSProxy.py", line 6, in <module>
    import roslib.rostime
ImportError: No module named rostime

I installed the rosbridge as a fuerte version: sudo apt-get install ros-fuerte-brown-remotelab. Since it is updated. why do I still have this problem? Also, I tried to run:

svn co http://brown-ros-pkg.googlecode.com/svn/trunk/experimental/rosbridge rosbridge

it says:

svn: 'rosbridge' is already a working copy for a different URL

so what should I do? Thanks.

edit retag flag offensive close merge delete

Comments

What URL does svn info report?

joq gravatar imagejoq ( 2012-07-09 09:55:50 -0600 )edit

Hi, joq, thanks! Problem solved already.

shuo gravatar imageshuo ( 2012-07-11 09:11:34 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-07-10 12:47:49 -0600

updated 2012-07-10 12:48:20 -0600

Hi Shuo,

This problem is caused by a change in ROS between electric and fuerte. The rostime module was moved from roslib to rospy. Thus, when importing roslib.rostime, we now get an ImportError

We have implemented a fix for this and it has been checked into the experimental version of rosbridge. As you mentioned in your post, you can check this out using

svn co http://brown-ros-pkg.googlecode.com/svn/trunk/experimental/rosbridge rosbridge

With regard to your svn error, I think you might be trying to SVN checkout into a folder that is already under SVN version control. Please try checking out experimental rosbridge into a fresh folder.

Finally, since you will probably have multiple rosbridge packages on your ROS package path, do a quick check to make sure that the experimental rosbridge is the first rosbridge that ROS finds. (Just roscd rosbridge and make sure that takes you to the folder that you just created)

This should fix your problem.

Cheers, Jon

edit flag offensive delete link more

Comments

In that case, could you please change the rosbag.bag documentation to reflect this change? This has been confusing me for a long time.

vlonge gravatar imagevlonge ( 2017-07-10 15:24:58 -0600 )edit
0

answered 2012-07-11 09:12:53 -0600

shuo gravatar image

@ Jon,thanks very much. Problem solved !

Cheers,

Shuo

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-09 08:22:43 -0600

Seen: 583 times

Last updated: Jul 11 '12