ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

rosbridge error in ROSProxy.py on Fuerte with roslib.rostime

asked 2012-05-12 00:43:28 -0500

Dave gravatar image

updated 2014-01-28 17:12:18 -0500

ngrennan gravatar image

rosbridge.py fails on Fuerte after trying to import roslib.rostime. It seems like this problem can be fixed by replacing all 3 instances of "roslib.rostime" in the code with "rospy.rostime" (although I haven't thoroughly tested this yet). I don't have any experience with the patching process, but I wanted to get this fix out there, and I would appreciate it if someone could update the code. Here was the original error:

Traceback (most recent call last): File "/opt/ros/fuerte/stacks/brown_remotelab/rosbridge/bin/rosbridge.py", line 2, in <module> from ROSProxy import ROSProxy File "/opt/ros/fuerte/stacks/brown_remotelab/rosbridge/bin/ROSProxy/__init__.py", line 1, in <module> from ROSProxy import ROSProxy File "/opt/ros/fuerte/stacks/brown_remotelab/rosbridge/bin/ROSProxy/ROSProxy.py", line 6, in <module> import roslib.rostime ImportError: No module named rostime

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-05-15 18:33:41 -0500

tjay gravatar image

Sorry it took so long to get this fixed, but the latest experimental version of rosbridge passes our regression test and should be fully Fuerte compatible.

As soon as we've done enough testing to make sure there are no hidden gotcha's we'll release a deb (apt-get) version.

In the meantime you can get this version via the usual SVN mechanism:

svn co http://brown-ros-pkg.googlecode.com/svn/trunk/experimental/rosbridge rosbridge

As I said, we're definitely looking to get this version thoroughly tested. Please let us know if you run into any further issues.

edit flag offensive delete link more

Comments

Thanks, I appreciate the fix! Rosbridge is a great tool!

Dave gravatar imageDave ( 2012-05-19 03:03:54 -0500 )edit
0

answered 2012-07-09 08:20:02 -0500

shuo gravatar image

I encountered the same problem here. When I tried to run rosbridge,it gave me the error with yours. I installed the rosbridge as a fuerte version: sudo apt-get install ros-fuerte-brown-remotelab. Since it is updated. why do I still have this problem? Also, I tried to run: svn co http://brown-ros-pkg.googlecode.com/svn/trunk/experimental/rosbridge rosbridge

it says: svn: 'rosbridge' is already a working copy for a different URL

so what should I do? Thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-12 00:43:28 -0500

Seen: 813 times

Last updated: Jul 09 '12