Ask Your Question
1

Turtlebot gazebo fuerte launch error [closed]

asked 2012-07-08 23:25:01 -0500

Saurabh gravatar image

Hi,

I am trying to launch the TURTLEBOT SIMULATOR for FUERTE. It runs into the following error.

roslaunch turtlebot_gazebo turtlebot_empty_world.launch . . Msg Waiting for master Msg Connected to gazebo master @ http://localhost:11345 loading model xml from ros parameter waiting for service spawn_urdf_model gzserver: /usr/include/boost/smart_ptr/shared_ptr.hpp:418: T* boost::shared_ptr<t>::operator->() const [with T = urdf::Inertial]: Assertion `px != 0' failed. Aborted Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details [gazebo-1] process has died [pid 11529, exit code 134, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo -u /opt/ros/fuerte/stacks/turtlebot_simulator/turtlebot_gazebo/worlds/empty.world __name:=gazebo __log:=/home/saurabh/.ros/log/2c86a0fa-c9a0-11e1-87cb-0008cab29001/gazebo-1.log]. log file: /home/saurabh/.ros/log/2c86a0fa-c9a0-11e1-87cb-0008cab29001/gazebo-1*.log . .

I am working on Ubuntu 11.10/ROS Fuerte...

Help please!!

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by tfoote
close date 2012-08-08 16:12:18

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-25 03:42:38 -0500

hcostelha gravatar image

See this answer.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-07-08 23:25:01 -0500

Seen: 576 times

Last updated: Jul 25 '12