ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
2

[rviz] Unable to create the rendering window

asked 2012-07-08 09:12:53 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi all, I want to run the simulation http://www.ros.org/wiki/urdf/Tutorials/Building%20a%20Visual%20Robot%20Model%20with%20URDF%20from%20Scratch

but as soon as i run command

roslaunch urdf_tutorial display.launch model:=01-myfirst.urdf

it gives me errors as listed below

process[rviz-3]: started with pid [8013]

Config file '/home/sanket/.rviz/config' could not be opened for reading.

Xlib: extension "GLX" missing on display ":0.0".

rviz::RenderSystem: error creating render window: std::exception

rviz: /tmp/buildd/ros-fuerte-visualization-1.8.13/debian/ros-fuerte-visualization/opt/ros/fuerte/stacks/visualization/rviz/src/rviz/ogre_helpers/render_system.cpp:263: Ogre::RenderWindow* rviz::RenderSystem::makeRenderWindow(intptr_t, unsigned int, unsigned int): Assertion `false' failed.

[rviz-3] process has died [pid 8013, exit code -6, cmd /opt/ros/fuerte/stacks/visualization/rviz/bin/rviz -d /opt/ros/fuerte/stacks/robot_model_tutorials/urdf_tutorial/urdf.vcg __name:=rviz __log:=/home/sanket/.ros/log/5e4ebc6c-c928-11e1-950f-848f69c0fd9c/rviz-3.log].

log file: /home/sanket/.ros/log/5e4ebc6c-c928-11e1-950f-848f69c0fd9c/rviz-3*.log

i don't know whether my rviz is missing some files or is it related to system requirements of my laptop

edit retag flag offensive close merge delete

Comments

Could you please reformat your question? Using code formatting or blockquotes makes console output much more readable (see here for some pointers). Thanks.

ipso gravatar image ipso  ( 2012-07-08 21:28:55 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-07-08 21:06:50 -0500

ipso gravatar image

updated 2012-07-08 21:07:07 -0500

It seems your X configuration is not properly set up for 3D accelerated OpenGL operation. GLX is the 'OpenGL Extension to the X Window System', which is required for this.

It seems you have more problems with this particular machine / setup? I noticed this question, which seems to be related.

I'd first sort out the OpenGL / Xorg setup on the machine (without involving ROS or rviz) and then try to tackle the rviz problems.

edit flag offensive delete link more
2

answered 2014-05-19 04:16:37 -0500

akash_b gravatar image

i also got similar error. i followed following steps:

  1. install nvidia drivers from ubuntu software centre.

  2. use additional driver utility to check if any driver is missing. In mine it showed nvidia drivers not active.So activate it and restart.

edit flag offensive delete link more

Comments

More specifically, to run the additional driver utility, type "Additional Drivers" in the Ubuntu Dash and select the additional drivers application. It starts a dialog that looks to see which additional drivers are installed and active. I found that the nvidia drivers were installed (because I installed them when I installed Ubuntu), but were not active. I pressed the "Activate" button for both the driver and the post-install update, rebooted after it was done installing/activating, and rviz suddenly worked.

PaulBouchier gravatar image PaulBouchier  ( 2014-07-27 03:41:55 -0500 )edit
0

answered 2012-07-08 21:24:21 -0500

Sanket_Kumar gravatar image

thnx i uninstalled my nvidia graphics and now its working fine...i think somehow it was related to them

edit flag offensive delete link more

Comments

1

(again): please use a comment ('post a comment') instead of an answer to comment on another answer. Answers can be reordered by votes, so there is no inherent chronological order to them, which can become confusing in the future.

ipso gravatar image ipso  ( 2012-07-08 21:26:15 -0500 )edit

Also, if the answer helped you, please accept it (checkmark).

ipso gravatar image ipso  ( 2012-07-08 21:26:44 -0500 )edit

sorry i m new to it....anyway thnx

Sanket_Kumar gravatar image Sanket_Kumar  ( 2012-07-08 21:29:22 -0500 )edit

You probably have a laptop with nvidia optimus technology? If so, do note that by uninstalling the drivers you are now only using the Intel graphics card. This may not be what you want. Optimus support on Linux is rather limited though, unfortunately.

ipso gravatar image ipso  ( 2012-07-08 21:32:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-08 09:12:53 -0500

Seen: 13,587 times

Last updated: May 19 '14