Ask Your Question
1

rviz error - Segmentation fault

asked 2012-09-16 04:59:18 -0600

Janina gravatar image

updated 2013-09-25 03:47:06 -0600

felix k gravatar image

I have installed ROS electric (Ubuntu 10.04).

I get this error message when I like to start rviz with rosrun rviz rviz:

INFO [1347807197.728174501]: rviz revision number 1.6.7
INFO [1347807197.728302839]: ogre_tools revision number 1.6.3
INFO [1347807197.728350850]: compiled against OGRE version 1.7.3 (Cthugha)
INFO [1347807197.801335753]: Loading general config from [/home/janina/.rviz/config]
INFO [1347807197.801921520]: Loading display config from [/home/janina/.rviz/display_config]
INFO [1347807197.850185850]: RTT Preferred Mode is Copy.
INFO [1347807198.050808370]: Texture for pass 0: creating with size 1 x 1
INFO [1347807198.051192494]: Texture for pass 1: creating with size 1 x 1
INFO [1347807199.082435434]: RTT Preferred Mode is Copy.

**Segmentation fault**

I tried export OGRE_RTT_MODE=Copy (also PBuffer, or FBO), but it does not work.

Does anybody know an other solution for this problem?

Thanks for help!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-16 20:09:59 -0600

Hi,

I'm also using electric and have this issue. However, depending on the exact Segfault message, it appears that it is fixed in fuerte and probably will not be fixed in electric.

I suggest you take a look here, sections 3 and 4 : http://www.ros.org/wiki/rviz/Troubleshooting

And, regards to specific errors... BadDrawable error : https://code.ros.org/trac/ros-pkg/ticket/5379

Mesa bug : See near bottom that shows "rosrun rviz rviz -sync" https://code.ros.org/trac/ros-pkg/ticket/4830

edit flag offensive delete link more
0

answered 2012-09-16 05:44:48 -0600

Well i do not know what is causing this problem but i can give you some hints which i us if rviz fails.

  1. If rviz was once working and is not any longer then something is wrong with the config file within your home folder. Delete the config file in /home/USERNAME/.rviz will help.

  2. IF rviz fails after software updated, then it can be that the graphi card driver needs to be reinstalled once more

Hope this helps

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-16 04:59:18 -0600

Seen: 2,121 times

Last updated: Sep 25 '13