Error: resource not found: lms1xx when making ros launch

asked 2021-06-15 16:55:08 -0500

MuskaTheCat gravatar image

Dear ROS users and enthusiasts,

Im learning ROS at university (Im still poorly experienced) and got an error after I tried to roslaunch a different programm from github in my workspace. After that I got this error, I deleted the programm i got from github and tried to launch a different exercise i have done, in which everything worked fine with roslaunch. But this time the same error occured, so somehow i crash my whole ros launch. After reading about the error in the internet I tried deinstalling ROS and installed it again, but the same error occured again. My system is running Ubuntu 20.04 with ROS 1 Noetic and I'm using the Catkin Command Line Tools with catkin build. Heres the whole error:

resource not found: lms1xx
ROS path [0]=/opt/ros/noetic/share/ros
ROS path [1]=/home/daniel/catkin_ws/src/husky/husky_bringup
ROS path [2]=/home/daniel/catkin_ws/src/husky/husky_control
ROS path [3]=/home/daniel/catkin_ws/src/husky/husky_description
ROS path [4]=/home/daniel/catkin_ws/src/husky/husky_desktop
ROS path [5]=/home/daniel/catkin_ws/src/husky/husky_gazebo
ROS path [6]=/home/daniel/catkin_ws/src/husky_highlevel_controller_ex3
ROS path [7]=/home/daniel/catkin_ws/src/husky/husky_msgs
ROS path [8]=/home/daniel/catkin_ws/src/husky/husky_base
ROS path [9]=/home/daniel/catkin_ws/src/husky/husky_navigation
ROS path [10]=/home/daniel/catkin_ws/src/husky/husky_robot
ROS path [11]=/home/daniel/catkin_ws/src/husky/husky_simulator
ROS path [12]=/home/daniel/catkin_ws/src/husky/husky_viz
ROS path [13]=/home/daniel/catkin_ws/src/teleop_twist_keyboard
ROS path [14]=/opt/ros/noetic/share
when processing file: /home/daniel/catkin_ws/src/husky/husky_description/urdf/accessories/sick_lms1xx_mount.urdf.xacro
included from: /home/daniel/catkin_ws/src/husky/husky_description/urdf/husky.urdf.xacro
RLException: while processing /home/daniel/catkin_ws/src/husky/husky_gazebo/launch/spawn_husky.launch:
while processing /home/daniel/catkin_ws/src/husky/husky_control/launch/control.launch:
while processing /home/daniel/catkin_ws/src/husky/husky_description/launch/description.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [['/opt/ros/noetic/lib/xacro/xacro', '/home/daniel/catkin_ws/src/husky/husky_description/urdf/husky.urdf.xacro', 'robot_namespace:=/', 'laser_enabled:=true', 'realsense_enabled:=0', 'urdf_extras:=']] returned with code [2]. 

Param xml is <param name="robot_description" command="$(find xacro)/xacro '$(find husky_description)/urdf/husky.urdf.xacro' robot_namespace:=$(arg robot_namespace)     laser_enabled:=$(arg laser_enabled)    realsense_enabled:=$(arg realsense_enabled)     urdf_extras:=$(arg urdf_extras)     "/>
The traceback for the exception was written to the log file

I would be very happy if someone could help me.

Thanks in advance!

edit retag flag offensive close merge delete