How to modify that projet to accept move_group_interface_tutorial

asked 2021-05-20 07:44:06 -0600

xavier12358 gravatar image


I find that working example of panda arm on gazebo:

I want to be able to use move_group_interface_tutorial on it. I modify the repo to add the moveit_tutorial folder and I build it.

When I run the command:

roslaunch moveit_tutorials move_group_interface_tutorial.launch

I get this error in terminal:

process[move_group_interface_tutorial-1]: started with pid [13168]
[ INFO] [1621513956.505344940]: Loading robot model 'panda'...
[ WARN] [1621513956.506668280]: Skipping virtual joint 'virtual_joint' because its child frame 'panda_link0' does not match the URDF frame 'world'
[ INFO] [1621513956.506706999]: No root/virtual joint specified in SRDF. Assuming fixed joint
[ WARN] [1621513956.563739821]: Group state 'ready' doesn't specify all group joints in group 'panda_arm_hand'. panda_finger_joint1 is missing.
[ WARN] [1621513956.594243503]: Kinematics solver doesn't support #attempts anymore, but only a timeout.
Please remove the parameter '/robot_description_kinematics/panda_arm/kinematics_solver_attempts' from your configuration.
[ INFO] [1621513957.899139768, 14.562000000]: Ready to take commands for planning group panda_arm.
[ INFO] [1621513958.113531876, 14.737000000]: RemoteControl Ready.
[ INFO] [1621513958.406453359, 14.994000000]: Planning frame: world
[ INFO] [1621513958.406525802, 14.994000000]: End effector link: panda_link8
[ INFO] [1621513958.406557427, 14.994000000]: Available Planning Groups:

It seems something have be badly defined in the movit config. I tried to modidy the panda_controller.yaml by adding virtual_joint and panda_finger_joint1:

  - name: panda_arm_controller
    action_ns: follow_joint_trajectory
    type: FollowJointTrajectory
    default: true
      - virtual_joint
      - panda_joint1
      - panda_joint2
      - panda_joint3
      - panda_joint4
      - panda_joint5
      - panda_joint6
      - panda_joint7
      - panda_finger_joint1

And add it into silumation.launch at the end like this:

    <!-- load (not start!) custom joint position controller -->

    <!-- run custom node for automatic intialization -->
    <node pkg="panda_simulation" type="robot_state_initializer_node" name="robot_state_initializer_node" />

    <include file="$(find panda_moveit_config)/launch/panda_moveit_controller_manager.launch.xml"/>

I still have the same error and the move_group_interface_tutorial always do strange think ( the plan is displayed and nothing happen)

edit retag flag offensive close merge delete