Ask Your Question
1

octomap_server problems [closed]

asked 2012-07-03 07:39:32 -0500

ChickenSoup gravatar image

updated 2016-05-17 02:34:43 -0500

Hi all,

I simulate a robot in gazebo while it maps the environment using octomap_server. I have 2 questions regarding the visualization.

1) the mapped octomap cells get cleared after some time if the robot does not re-visit the area previously mapped. Why is this happenning?

2) why the colors of the octomap changing after a while?

Thank you

CS

########## Edit ##########

Running ROS-Groovy ros-groovy-octomap 1.5.4 ros-groovy-octomap-mapping 0.4.8 ros-groovy octomap-ros 0.2.6

The second image shows that areas previously filled had been removed after some time. initial octomap after 5 minutes

launch file

      <param name="resolution" value="0.2" />        
      <param name="frame_id" type="string" value="/map" />

      <!-- maximum range to integrate (speedup!) -->
      <param name="sensor_model/max_range" type="double" value="30.0" />

      <!-- data source to integrate (PointCloud2) -->
      <remap from="cloud_in" to="/snapshotter/assembled_cloud" />
      <param name="latch" type="bool" value="false" />
      <param name="height_map" type="bool" value="true" />      
      <param name="sensor_model/[hit|miss]" value="0.9 / 0.1" />
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Martin Günther
close date 2016-05-17 03:28:46.547630

Comments

What kind of sensor are you using, and where is is mounted?

AHornung gravatar image AHornung  ( 2013-05-13 22:37:16 -0500 )edit

@AHornung I am using a tilting laser similar to the one in PR2. It is mounted on a mast in the front (slightly visible in the first image).

ChickenSoup gravatar image ChickenSoup  ( 2013-05-13 23:38:29 -0500 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-05-14 23:41:24 -0500

AHornung gravatar image

As Stefan wrote, octomap_server does not delete nodes on its own. It seems like you are partially clearing cells (setting them to free) with rays that pass through them. Your laser probably has a field of view larger than 180°? The clearing happens when you have the ground filter enabled or misconfigured in octomap_server, or when you are inserting complete 3D scans ray by ray from a shallow angle. This is described in our paper (http://www.informatik.uni-freiburg.de/~hornunga/pub/hornung13auro.pdf) in Fig 10 and 11. If you insert a complete pointcloud in batch from one tilt, this effect should disappear.

edit flag offensive delete link more
2

answered 2013-05-05 21:10:23 -0500

1) AFAIK, this shouldn't be happening with the plain OctomapServer. Last time I checked, it only added point clouds, but never cleared parts of the tree based on time. Can you edit you post with more details (which version do you use, which kind of sensor data etc.)

For 2) see answer here

edit flag offensive delete link more

Comments

Thank you for your response. I have edited the original question.

ChickenSoup gravatar image ChickenSoup  ( 2013-05-12 20:44:12 -0500 )edit
-1

answered 2013-05-05 20:23:42 -0500

elva gravatar image

hi, also have the color changing problem in octomap, the color seems to be ok at the first scan,however after a while the color in different height tend to change to the same color .may i know how did you solve this problem?thks:)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-03 07:39:32 -0500

Seen: 886 times

Last updated: May 17 '16