Ask Your Question
0

OccupangyGrid map Issue: ray_ground_filter fails to generate costmap on AutowareAI

asked 2021-05-04 14:08:42 -0500

Vini71 gravatar image

updated 2021-05-04 19:14:30 -0500

I have recorded a video where the self-driving car fails to recognize a car obstacle in Occupancy Grid map:

https://www.youtube.com/watch?v=XSKYE...

This issue is related to: https://answers.ros.org/question/3773...

I did not figured out the reason why the /semantics/costmap_generator/occupancy_grid does not recognize the AGENT car or pedestrian as obstacle. When I echoed this topic, it returns usually an inifinite array of ZEROs values. However sometimes it returns the value 100:

`$ rostopic echo /semantics/costmap_generator/occupancy_grid

0, 0, 0, 0, 100, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 100, 0, 100, 0, 0, 100, 0, 0, 0, 0, 100, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 100, 0, 100, 100, 0, 0, 0, 0, 0, 100, 100, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 100, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 100, 0, 0, 0, 0, 0, 0, 0,....]`

The terminal that outputs the runtime_manager launched modules, always display this warning message:

Lookup would require extrapolation into the past. Requested time 1620142061.472442880 but the earliest data is at time 1620142284.496077775, when looking up transform from frame [velodyne] to frame [base_link]

And this error message:

[ERROR] [1620142288.442861565]: Failed transform from base_link to velodyne

However when I run the commands:

```
$rosrun tf view_frames
$ evince frames.pdf
```

I get this TF: frames.pdf

Afterwards I checked again if the TF exist with the cmd:

`$rosrun tf tf_echo base_link velodyne:`

At time 1620141918.625
- Translation: [0.368, 0.000, 1.975]
- Rotation: in Quaternion [0.000, 0.000, 0.000, 1.000]
            in RPY (radian) [0.000, -0.000, 0.000]
            in RPY (degree) [0.000, -0.000, 0.000]
At time 1620141919.617
- Translation: [0.368, 0.000, 1.975]
- Rotation: in ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-05-18 10:40:26 -0500

Vini71 gravatar image

updated 2022-01-19 11:57:29 -0500

The solution is to activate on costmap_generator TAB, the lanelet2 checkbox, otherwise, the occupancy_grid map won't be generated....in addition, a powerful machine will provide better results and a quicker generation of occupancy_grid map.

Here to send the solution for some users that faced the same issue

. The tutorials that I have followed and described above in my question are WRONG! If you launch the costmap_generator through the runtime manager or terminal, the occupancy grid map will not be generated or very very rarely.... To fix this there are 2 options:

1). Using Run-time Manager: on Computing Tab click over app option in costmap_generator, scroll down until you find the Lanelet2 checkbox option at the left bottom. CHECK this box ✔️

2) Inside the docker, using a new terminal launch: roslaunch costmap_generator costmap_generator_lanelet2.launch Ok now the costmap_generator will generate the occupancy_grid_map

3) Just Pay attention that you must check the ray_ground filter or compare_map_filter on Sensing Tab

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-05-04 14:08:42 -0500

Seen: 164 times

Last updated: Jan 19