Ask Your Question
0

Fuerte, Ubuntu 12.04, ARM = error

asked 2012-06-23 05:39:01 -0500

updated 2014-01-28 17:12:47 -0500

ngrennan gravatar image

Just following instructions on http://www.ros.org/wiki/fuerte/Installation/Ubuntu

robot@robot:~$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu precise main" > /etc/apt/sources.list.d/ros-latest.list'
robot@robot:~$ wget http://packages.ros.org/ros.key -O - | sudo apt-key add -
--2012-06-24 00:34:40--  http://packages.ros.org/ros.key
Resolving packages.ros.org (packages.ros.org)... 157.22.19.137
Connecting to packages.ros.org (packages.ros.org)|157.22.19.137|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1162 (1.1K) [application/pgp-keys]
Saving to: `STDOUT'

100%[=============================================================================================>] 1,162       --.-K/s   in 0s      

2012-06-24 00:34:41 (18.2 MB/s) - written to stdout [1162/1162]

OK
robot@robot:~$ 
robot@robot:~$ sudo apt-get update
Ign http://packages.ros.org precise InRelease
Hit http://packages.ros.org precise Release.gpg     
Ign http://ports.ubuntu.com precise InRelease       
Ign http://ports.ubuntu.com precise-updates InRelease
Ign http://ports.ubuntu.com precise-security InRelease
Hit http://packages.ros.org precise Release
Hit http://ports.ubuntu.com precise Release.gpg 
Hit http://ports.ubuntu.com precise-updates Release.gpg
Hit http://ports.ubuntu.com precise-security Release.gpg
Hit http://ports.ubuntu.com precise Release
Hit http://ports.ubuntu.com precise-updates Release
Hit http://ports.ubuntu.com precise-security Release
Hit http://ports.ubuntu.com precise/main Sources
Hit http://ports.ubuntu.com precise/restricted Sources
Hit http://ports.ubuntu.com precise/universe Sources
Hit http://ports.ubuntu.com precise/multiverse Sources
Hit http://ports.ubuntu.com precise/main armhf Packages
Hit http://ports.ubuntu.com precise/restricted armhf Packages
Hit http://ports.ubuntu.com precise/universe armhf Packages
Hit http://ports.ubuntu.com precise/multiverse armhf Packages
Hit http://ports.ubuntu.com precise/main TranslationIndex
Hit http://ports.ubuntu.com precise/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise/restricted TranslationIndex
Hit http://ports.ubuntu.com precise/universe TranslationIndex
Hit http://ports.ubuntu.com precise-updates/main Sources
Hit http://ports.ubuntu.com precise-updates/restricted Sources
Hit http://ports.ubuntu.com precise-updates/universe Sources
Hit http://ports.ubuntu.com precise-updates/multiverse Sources
Hit http://ports.ubuntu.com precise-updates/main armhf Packages
Hit http://ports.ubuntu.com precise-updates/restricted armhf Packages
Hit http://ports.ubuntu.com precise-updates/universe armhf Packages
Hit http://ports.ubuntu.com precise-updates/multiverse armhf Packages
Hit http://ports.ubuntu.com precise-updates/main TranslationIndex
Hit http://ports.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://ports.ubuntu.com precise-updates/universe TranslationIndex
Hit http://ports.ubuntu.com precise-security/main Sources
Hit http://ports.ubuntu.com precise-security/restricted Sources
Hit http://ports.ubuntu.com precise-security/universe Sources
Hit http://ports.ubuntu.com precise-security/multiverse Sources
Hit http://ports.ubuntu.com precise-security/main armhf Packages
Hit http://ports.ubuntu.com precise-security/restricted armhf Packages
Hit http://ports.ubuntu.com precise-security/universe armhf Packages
Hit http://ports.ubuntu.com precise-security/multiverse armhf Packages
Hit http://ports.ubuntu.com precise-security/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/multiverse TranslationIndex
Hit http ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2012-06-23 05:51:31 -0500

And as usually happens, after asking I seem to found solution myself. Two things to be done:

  1. Make new file /etc/dpkg/dpkg.cfg.d/multiarch containing one line only:

    foreign-architecture armel

  2. Add [arch=armel] into /etc/apt/sources.list.d/ros-latest.list like this:

    deb [arch=armel] http://packages.ros.org/ros/ubuntu precise main

Now "apt-get update" was able to fetch all he needs.

edit flag offensive delete link more

Comments

And stuck again. There is no ROS packages to install with apt-get install :(. Nothing shown in install instructions works for ARM.

Tõnu Samuel gravatar image Tõnu Samuel  ( 2012-06-23 05:57:47 -0500 )edit

Willow Garage is not currently building any binary packages for ARM, so you shouldn't expect to find any with apt-get. You could try installing from source, but many things will likely be broken on ARM. Was there someplace on the wiki that led you to believe ARM packages should be available?

Eric Perko gravatar image Eric Perko  ( 2012-06-23 12:36:31 -0500 )edit

Wiki says ubuntu is OK and I do have ubuntu. Also as indicated I found some armel directory and assumed I just do something wrong.

Tõnu Samuel gravatar image Tõnu Samuel  ( 2012-06-24 01:46:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-23 05:39:01 -0500

Seen: 1,778 times

Last updated: Jun 23 '12