ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

ROS Noetic networking, host is not set to this machine, tried everything

asked 2020-12-01 22:44:32 -0600

cjonesy gravatar image

Really hoping someone can help me with this. I have a Raspberry Pi running ROS Noetic as a Master and an Ubuntu VM as the Slave and am trying to get them to connect. I tried the ROS Networking troubleshooting guide.

I can ping both ways by hostname and IP, ssh bidrectionally, and netcat bidirectionally. I tried ROS_HOSTNAME and ROS_IP and ROS_MASTER_URI by IP and hostname. Everytime I get WARNING ROS_MASTER_URI host is not set to this machine.

Here's a Youtube screen capture of me trying all of this with the same result each time. https://www.youtube.com/watch?v=y_0Jg...

Trying to get this working for a final project for my final Masters CS course. Would love to graduate! Thanks for any help.

edit retag flag offensive close merge delete

Comments

did you source the bashrc after adding the export ROS_MASTER_URI = http://192.168..**:11311 ?

AmirSaman gravatar image AmirSaman  ( 2020-12-01 23:41:08 -0600 )edit

I realise videos can be convenient, but if (or when) your video disappears (and they tend to do that), there will be no information left in your question which future readers can use to determine what it was that you tried, and what happened.

It would be very much appreciated if you could at least summarise what settings you tried and what you observed when testing them.

We try to make/keep questions (and answers) stand-alone, similar to sites like Stack Overflow and Stack Exchange.

gvdhoorn gravatar image gvdhoorn  ( 2020-12-02 02:59:30 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-12-02 02:15:11 -0600

lslabon gravatar image

updated 2020-12-02 03:09:34 -0600

You are supposed to run only one roscore on the master. So in your network configuration it is not nescessary to run roscore on your remote PC while running on raspberrry pi (master) - As long as its running on your raspi you can launch any file on your remote PC.

So far I do not see any problem in your setup/ Youtube video :)

edit flag offensive delete link more

Comments

That was simple, when I ran rosrun list on the slave (ubuntu.lan) all the nodes show up. I was thinking that running roscore wasn't required but that it would just connect to the master and was a simple way for me to tell if it connected. Thanks!

cjonesy gravatar image cjonesy  ( 2020-12-02 11:49:32 -0600 )edit

Question Tools

4 followers

Stats

Asked: 2020-12-01 22:44:32 -0600

Seen: 864 times

Last updated: Dec 02 '20