ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Invoking "cmake" failed error

asked 2020-12-01 12:10:53 -0600

Inadu gravatar image

I'm using ROS Noetic and a beginner, when I ran command for creating ros package called beginner_tutorials, after that I ran the command $ catkin_make but it shows Invoking "cmake" error. And after that even I ran the command $ roscd beginner_tutorials but it's showing no directory exists error. Please help me out to solve this error.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-01 14:33:03 -0600

Joao gravatar image

For roscd to work you need to source you catkin_ws/devel/setup.bash add a line in file .bashrc

source <catkin_ws>/devel/setup.bash

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-12-01 12:10:53 -0600

Seen: 400 times

Last updated: Dec 01 '20