Ask Your Question
0

Command 'rqt' not found

asked 2020-11-15 09:20:27 -0500

tonydavies gravatar image

Hi all, sorry for a noob question. I have been following the setup of ROS from the instructions. Everything worked at described until the rqt installation. The instructions say

  • sudo apt update
  • sudo apt install ~nros-<distro>-rqt*

I am using foxy so the 2nd command was sudo apt install ~nros-foxy-rqt*

both commands completed error free, but when I typed rqt to start the app as per instructions I get command 'rqt' not found. I know rqt is installed because if I try to install it again I get a series of messages like this

ros-foxy-rqt is already the newest version (1.0.6-1focal.20201103.154403). ros-foxy-rqt-action is already the newest version (1.0.1-1focal.20201103.152809).

I expect this is a search path problem, but I can't find the location or the filename of the rqt app. I am not a linux person, I am more comfortable in windows, but thought I'd use linux as I'd read the windows port is still experimental.

I am using Ubuntu 20.04. Its a fresh install, the only installs I have done are Pycharm and the ROS 2 installs from the instructions. I installed ROS via the Debian packages, so I assumed default locations for files were used? Any help will be appreciated.

Thanks

Tony

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2020-11-16 11:29:54 -0500

jacobperron gravatar image

It sounds like you were following the turtlesim and rqt tutorial. This tutorial expects you have sourced your ROS 2 installation, as described in the first tutorial. For example for Foxy on Ubuntu:

source /opt/ros/foxy/setup.bash

This command should be run in every terminal that you open when you expect to run ROS commands.

We could probably add a reminder to run this command in the new terminal before running rqt.

edit flag offensive delete link more

Comments

thanks, that sounds like it might have been the cause. I did read the line where it said you had to source the code in each window and I thought I had, but can't have

tonydavies gravatar image tonydavies  ( 2020-11-16 11:53:17 -0500 )edit
0

answered 2020-11-16 10:34:21 -0500

tonydavies gravatar image

OK, I got it to work and I not sure why it worked. I just opened another terminal session, did the source copy and it worked.

I realise my linux skills are lacking, so I've enrolled on a linux fundamentals course to help there. I don't really like copy/pasting commands without knowing what I am asking the system to do. ROS seems like a steep learning curve, should be a fun ride!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-15 09:20:27 -0500

Seen: 1,127 times

Last updated: Nov 16 '20