Ask Your Question
1

Compiling on Linux Mint 11

asked 2011-06-01 22:05:53 -0500

I'm attempting to compile a package on Linux Mint 11, which is based upon Ubuntu 11.04, but am getting the following errors which looks as if they're related to detecting the OS version number.

  File "/opt/ros/diamondback/ros/bin/rosmake", line 65, in <module>
    if rma.main():   
  File "/opt/ros/diamondback/ros/tools/rosmake/src/rosmake/rosmake.py", line 858, in main
    (self.rosdep_check_result, warning) = self.check_rosdep(buildable_packages)  
  File "/opt/ros/diamondback/ros/tools/rosmake/src/rosmake/rosmake.py", line 287, in check_rosdep
    r = rosdep.core.Rosdep(packages, robust=True)   
  File "/opt/ros/diamondback/ros/tools/rosdep/src/rosdep/core.py", line 296, in __init__
    self.osi = roslib.os_detect.OSDetect(os_list)
  File "/opt/ros/diamondback/ros/core/roslib/src/roslib/os_detect.py", line 479, in __init__
    self.detect_os()
  File "/opt/ros/diamondback/ros/core/roslib/src/roslib/os_detect.py", line 498, in detect_os
    self._os_version = os_class.get_version()
  File "/opt/ros/diamondback/ros/tools/rosdep/src/rosdep/debian.py", line 124, in get_version
    return self.version_map[self.mint_detector.get_version()] KeyError: '11'

Any ideas on how to fix this? The binary installation for Ubuntu 11.04 (natty) seems to have worked ok.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-06-02 06:09:10 -0500

updated 2011-06-02 06:35:17 -0500

It looks like a bug. You should probably file a ticket.(may require login, let me know if you'd like me to file it on your behalf)

The mint specialization apparently has not been updated since Ubuntu 10.04.

It should work if you edit:

/opt/ros/diamondback/ros/tools/rosdep/src/rosdep/debian.py

near line 118 there's a list that looks like this:

self.version_map = {'9':'10.04',
                    '8':'9.10',
                    '7':'9.04',
                    '6':'8.10',
                    '5':'8.04'}

add "'11':'11.04'," to that list and it should work. (and '10':'10.10' for that matter)

edit flag offensive delete link more

Comments

That seems to have resolved the problem. You can file it as a bug if you wish.
JediHamster gravatar image JediHamster  ( 2011-06-02 06:38:10 -0500 )edit
I don't wish to, but I will since it probably won't get fixed otherwise.
Asomerville gravatar image Asomerville  ( 2011-06-02 06:43:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-01 22:05:53 -0500

Seen: 711 times

Last updated: Jun 02 '11