Ask Your Question
0

Trouble using apt to install ROS Noetic on Raspberry PI

asked 2020-10-02 12:16:40 -0500

cjonesy gravatar image

Using a Raspberry Pi 4 with Raspberry Pi OS - Buster. I installed Noetic from source and it's running. I have custom messages and nodes and can pass data between them.

I'm trying to setup rosbridge_server and had to manually install Mongo and a few other libraries using PIP. I'm running into an issue with rosbridge and was told to install those dependencies using rosdep.

So I run rosdep check rosbridge_server and it tells me a number of decencies are missing and to install them with apt but I can't get any to install.

sudo apt install ros-noetic-rosauth says unable to locate package ros-noetic-rosauth.

pi@raspberrypi:/etc/apt/sources.list.d $ cat ros-noetic.list
deb http://packages.ros.org/ros/ubuntu buster main

apt search noetic returns no results either.

I think I have this setup correctly. Any ideas?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2020-10-15 07:43:00 -0500

duck-development gravatar image

I kown it is simple but did you run an sudo apt update?

edit flag offensive delete link more
0

answered 2020-10-14 11:23:57 -0500

DrBot gravatar image

ubuntu-20.04.1-preinstalled-server-arm64+raspi.img.xz This image +

sudo apt install ros-noetic-desktop-full following the step by step ROS instructions worked for me.

usb_cam could see the Raspberry Pi camera.

Some nodes like raspicam_node would not catkin_make, because the ARM64 architecture does not fully support certain features like raspi-config, raspistill so the MMAL architecture is not available. V4L2 is available.

gpu_mem=128
startx=1

need to be added to the /boot/firmware/config.txt (adding them to usercfg.txt has no effect -GRRR.)

Other gottchas - remember you are on python3 - so any .py executables that refer to a 'python' environment will generate a 'missing' error message.

I have seen instructions for installing noetic on Rpi 4 using the Debian Buster image, but I don't think this uses the ARM64 architecture. I looked at the Mate image, but it appears to have the same restrictions as the one I got working.

edit flag offensive delete link more
0

answered 2020-10-02 12:56:24 -0500

chives_onion gravatar image

Looking at the ROS docs for rosauth (here), the Jenkins jobs doesn't list a binary for debian buster armhf, so you won't be able to directly pull it on a RPi. There's a couple of solutions you could try:

1) submit an issue with the maintainers on their git asking if they plan on compiling a binary

2) compile it directly from source

3) A little round about, but my personal suggestion, you could run your ROS application within Docker containers and base the image off ubuntu. This would have a bit of a learning curve and potentially require you to set up a crosscompile environment, but in the end you'd benefit from greater control of your environment and general bonuses from containerization.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-10-02 12:16:40 -0500

Seen: 2,005 times

Last updated: Oct 15 '20