Ask Your Question
0

Issue with gazebo ros control

asked 2020-08-21 07:53:14 -0500

msaws gravatar image

when I run sudo apt-get install ros-melodic-gazebo-ros-control it gives me

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ros-melodic-gazebo-ros-control is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ros-melodic-gazebo-ros-control' has no installation candidate

how do I solve this?

I have ros melodic and gazebo 9.14.0

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2020-08-23 12:54:27 -0500

msaws gravatar image

I had to run this

wget http://packages.osrfoundation.org/gazebo.key -O - | sudo apt-key add -

sudo apt-get update
sudo apt-get install ros-melodic-gazebo9-ros-control

and it solved my error

edit flag offensive delete link more
0

answered 2020-08-21 17:14:44 -0500

rydb gravatar image

The reason it could be failing could be due to the way you installed ROS2, your particular OS, the way you installed gazebo, etc because those things effect weather a package can be installed or not. Please read http://wiki.ros.org/Support for guidelines on how to submit a clearer question so we can help!

edit flag offensive delete link more

Comments

@rydb I don't have ROS2, I'm on ROS1 melodic and I installed ros desktop full version on Ubuntu 18.04. other dependencies are installed without any problem like joint position control, joint effort control etc

msaws gravatar image msaws  ( 2020-08-21 23:51:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-08-21 07:53:14 -0500

Seen: 434 times

Last updated: Aug 23 '20