Ask Your Question
0

cmake error: "A required package was not found"

asked 2020-06-15 11:33:33 -0500

brunnese gravatar image

updated 2020-06-15 11:48:28 -0500

gvdhoorn gravatar image

Hi,

I cloned a bitbucket respo to my catkin_ws/src folder. everything works fine until I build mabi_speedy12. The steps in the README file are the following:

$ cd ~/catkin_ws
$ catkin config --cmake-args -DCMAKE_BUILD_TYPE=Release
$ cd src
$ ./mabi_common/mabi_speedy12/bin/clone_deps.sh 
$  catkin build mabi_speedy12

It can build some packages but it aborts at some point as it comes across the following error:

CMake Error at /usr/share/cmake-3.10/Modules/FindPkgConfig.cmake:415 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.10/Modules/FindPkgConfig.cmake:593 (_pkg_check_modules_internal)
  CMakeLists.txt:142 (pkg_check_modules)

Has anyone any idea how to solve this error? I tried looking up the error online but I couldn't find anything on the matter.

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Could you please try searching for previous Q&As about this topic (use Google and append site:answers.ros.org to your query). There should be multiple. If something is still not clear after reading those, please update your post here.

If reading those answers your question, please close this one as a duplicate.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-15 11:49:33 -0500 )edit

I found the following with the same errors but one doesn't propose a solution and the other one I don't understand how they fixed the error and how to apply it to my case.

https://answers.ros.org/question/2280...
https://answers.ros.org/question/2119...

So the question is still open for me

brunnese gravatar image brunnese  ( 2020-06-16 05:20:33 -0500 )edit
1

Is #q208963 the one you don't understand?

See #q252478 for a similar Q&A, which also includes some text on why you can't just clone a repository and expect things to work.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-16 05:22:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-03-17 22:20:32 -0500

Rufus gravatar image

updated 2021-03-17 22:21:41 -0500

You might want to run

rosdep install --from-paths . --ignore-src --rosdistro <your distro> -yr

to make sure all dependencies required by the package are installed

edit flag offensive delete link more

Comments

You might want to run

rosdep install --from-paths . --ignore-src --rosdistro <your distro> -yr

to make sure all dependencies required by the package are installed

+1 for the example command line, but please remove the -r option.

It will cause rosdep to ignore any problems when trying to install dependencies, and return "success" after it completes, even if it couldn't install something.

This will lead many users to believe everything was OK, only to run into problems when they try to build their workspace as some (or multiple) dependencies still haven't been installed.

gvdhoorn gravatar image gvdhoorn  ( 2021-03-18 03:58:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-06-15 11:33:33 -0500

Seen: 1,582 times

Last updated: Mar 17