ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

CMake Error Findurdf.cmake

asked 2015-03-05 08:50:18 -0500

bluefish gravatar image

updated 2015-03-05 08:51:10 -0500


I'm running the UR5-package on indigo against Ubuntu 14.04. Everything works fine, but since a while I get the following error when catkin_make my workspace.

CMake Error at /opt/ros/indigo/share/kdl_parser/cmake/kdl_parserConfig.cmake:165 (find_package):
  By not providing "Findurdf.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "urdf", but
  CMake did not find one.

  Could not find a package configuration file provided by "urdf" with any of
  the following names:


  Add the installation prefix of "urdf" to CMAKE_PREFIX_PATH or set
  "urdf_DIR" to a directory containing one of the above files.  If "urdf"
  provides a separate development package or SDK, be sure it has been
Call Stack (most recent call first):
  /opt/ros/indigo/share/moveit_core/cmake/moveit_coreConfig.cmake:165 (find_package)
  /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package)
  universal_robot/ur_kinematics/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/geissler/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/geissler/catkin_ws/build/CMakeFiles/CMakeError.log".
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

I did not knowingly change anything. Anybody knows where that does come from?

Best regards

P.S.: please note I'm a beginner concerning ROS...

edit retag flag offensive close merge delete


Just to make sure: try deleting your build/ and devel/ directories. Then rebuild your workspace.

gvdhoorn gravatar image gvdhoorn  ( 2015-03-05 10:46:35 -0500 )edit

I deleted both, rebuilt the workspace but got the same error then :(

bluefish gravatar image bluefish  ( 2015-03-06 01:10:45 -0500 )edit

As described in the answer I chose the way of reinstalling ROS and it is working. Thanks for your support!! :)

bluefish gravatar image bluefish  ( 2015-03-06 04:02:27 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-03-06 04:00:29 -0500

bluefish gravatar image

Okay, I uninstalled ROS completely (debian packages and their configs) via

sudo apt-get purge ros-indigo-*

and reinstalled it like described in the tutorial. Then reinstalled the moveit-package and catkin_make the workspace and everything is working well again. (I did not change the workspace).

I guess something was broken in the opt/ros/* folders. Weird...

Thanks gvdhoorn for support!!

edit flag offensive delete link more

answered 2015-03-06 03:34:59 -0500

gvdhoorn gravatar image

updated 2015-03-06 03:35:12 -0500

I've just tried to reproduce this on an up-to-date (2015-03-06) Indigo install with a clone of universal_robot in a catkin workspace. Everything compiles normally for me. Are you using the debians of universal_robot, or a from-source? Could you try a fresh workspace?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-03-05 08:50:18 -0500

Seen: 3,658 times

Last updated: Mar 06 '15