ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Asus Xtion camera calibration fails to start.

asked 2012-05-31 20:56:12 -0500

liborw gravatar image

updated 2012-06-01 02:01:01 -0500


I'm trying to calibrate Asus Xtion following tutorial in openni_launch package. I'm getting following error:

$ rosrun camera_calibration --size 8x6 --square 0.030 image:=/camera/rgb/image_raw camera:=/camera/rgb
Waiting for service /camera/rgb/set_camera_info ...
Exception in thread Thread-3:
Traceback (most recent call last):
  File "/usr/lib/python2.6/", line 532, in __bootstrap_inner
  File "/opt/ros/electric/stacks/image_pipeline/camera_calibration/nodes/", line 68, in run
  File "/opt/ros/electric/stacks/image_pipeline/camera_calibration/nodes/", line 133, in handle_monocular
    drawable = self.c.handle_msg(msg)
  File "/opt/ros/electric/stacks/image_pipeline/camera_calibration/src/camera_calibration/", line 684, in handle_msg
    rgb = self.mkgray(msg)
  File "/opt/ros/electric/stacks/image_pipeline/camera_calibration/src/camera_calibration/", line 233, in mkgray
    rgb =, "bgr8")
  File "/opt/ros/electric/stacks/vision_opencv/cv_bridge/src/cv_bridge/", line 106, in imgmsg_to_cv
    source_type = self.encoding_as_cvtype(img_msg.encoding)
  File "/opt/ros/electric/stacks/vision_opencv/cv_bridge/src/cv_bridge/", line 54, in encoding_as_cvtype
    return eval("cv.CV_%s" % encoding)
  File "<string>", line 1, in <module>
AttributeError: 'module' object has no attribute 'CV_yuv422'

I'm running electric.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-07-09 13:35:58 -0500

Smot gravatar image

Hi, I had the same problem (using Fuerte), but I was able to calibrate my Asus Xtion by changing the launch call to:

rosrun camera_calibration --size 10x7 --square 0.025 image:=/camera/rgb/image_mono camera:=/camera/rgb --no-service-check

for the RGB camera, and:

rosrun camera_calibration --size 10x7 --square 0.025 image:=/camera/ir/image_raw camera:=/camera/ir --no-service-check

for the IR camera.

Hope this helps.

edit flag offensive delete link more



(Also on Fuerte) Worked for me, thanks! I didn't need the --no-service-check, just the switch from image:=/camera/rgb/image_raw to /camera/rgb/image_mono

tbernhard gravatar image tbernhard  ( 2012-07-11 03:31:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2012-05-31 20:56:12 -0500

Seen: 1,672 times

Last updated: Jul 09 '12