Ask Your Question
0

Turtlebot3 NOT moving properly in simulation

asked 2020-05-13 08:18:42 -0500

Fredzibob gravatar image

Im trying to run a simple autonomous SLAM session. When I run my world, the turtle bot starts moving in a weird north/east kinda of trajectory. Even before the simulation node is started... When I start the simulation node, it changes nothing.

Heres an image of the RVIS map: https://pasteboard.co/J8beFVR.png Heres an image of the gazebo screen (the robots is the little dot in the right site: https://pasteboard.co/J8beUbf.png Heres an image of the terminals: https://pasteboard.co/J8bffYl.png

First I run: roslaunch turtlebot3_gazebo warehouse.launch to open the world in gazebo - That this is where the robot starts moving. Which it shouldnt... right?

then: roslaunch turtlebot3_slam turtlebot3_slam.launch slam_methods:=gmapping Lastly i run the simulation: roslaunch turtlebot3_gazebo turtlebot3_simulation.launch

Once the robot runs into a wall, it stands still for a while and then start spinning slowly. But nothing more

Any helps is appreciated guys :) Anything youve seen before? Im running ROS melodic on ubuntu 18.04

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-05-21 03:42:26 -0500

Fredzibob gravatar image

I downgraded to Ubuntu 16.04 and ROS Kinetic, and then everything worked as it should. Hope it helps some of you :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-05-13 07:44:12 -0500

Seen: 287 times

Last updated: May 21 '20