ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Using navigation_stack with a fixed map and no amcl

asked 2020-05-12 00:34:11 -0600

zoidberg2010eaf gravatar image

updated 2020-05-12 00:34:26 -0600

Hello, I have robot that uses the ekf node in the robot_localization package and a static map that I can load onto the map_server and I used a static tf publisher to publish frame info from odom to map. I would be able to provide the robot with its initial position (assuming the robot will always start from a fixed point on the map), so I don't need amcl. The problem is that when I send a goal pose to the robot, the path created will penetrate the obstacle areas in that map as shown the screenshot.

image description

Does anybody have any idea how to use a static map with ekf only (no amcl)?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-05-12 20:27:30 -0600

billy gravatar image

AMCL doesn't do any path planning so that isn't related to your issue. Move_base calls path planners that use costmaps to do the planning so make sure your costmaps are set up properly which is covered in the navigation stack tutorials.

edit flag offensive delete link more

Comments

Yes my problem with the global costmap configuration not with the localization. Thank you.

zoidberg2010eaf gravatar image zoidberg2010eaf  ( 2020-05-14 10:37:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-05-12 00:34:11 -0600

Seen: 131 times

Last updated: May 12 '20