Interactive marker not visible in moveit_config

asked 2020-03-03 02:10:43 -0500

Markus gravatar image

Hey there,

I created a moveit_config package with the setup assistant and defined an endefector as well. However when I launch the following file I do not see the interactive marker to move the endefector in xyz

This is not a duplicate of here

This is my launch file <include file="$(find kuka_30HA_moveit_config)/launch/planning_context.launch"> <arg name="load_robot_description" value="true"/> </include>

 <node pkg="tf2_ros" type="static_transform_publisher" name="virtual_joint_broadcaster_1" args="0 0 0 0 0 0 world base_link" />


 <!-- We do not have a robot connected, so publish fake joint states -->
 <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
   <param name="/use_gui" value="false"/>
   <rosparam param="/source_list">[/joint_states]</rosparam> <!-- remap to published ones! -->
 </node>

 <!-- Run the main MoveIt executable without trajectory execution (we do not have controllers configured by default) -->
 <include file="$(find kuka_30HA_moveit_config)/launch/move_group.launch">
   <arg name="allow_trajectory_execution" value="false"/>
   <arg name="fake_execution" value="true"/>
   <arg name="info" value="true"/>
   <arg name="debug" value="false"/>
   <arg name="pipeline" value="ompl"  />
 </include>

Is it possible to start the interactive marker somehow?

image description

edit retag flag offensive close merge delete

Comments

1

The IM is only shown for groups with a (working) IK solver.

You'll have to make sure you have one configured.


Edit: also:

 <rosparam param="/source_list">[/joint_states]</rosparam> <!-- remap to published ones! -->

this doesn't really make sense. The JSP by default will publish on /join_states, and by configuring source_list like this, it will receive its own messages. What are you trying to accomplish?

gvdhoorn gravatar image gvdhoorn  ( 2020-03-03 03:16:24 -0500 )edit