Ask Your Question
2

roscore failed to start

asked 2012-05-16 17:23:19 -0500

Roman Burdakov gravatar image

updated 2014-01-28 17:12:21 -0500

ngrennan gravatar image

Hi there. Recently I came across a problem with roscore. The only thing I can tell is the following log:

irobot@irobot-desktop:/opt/ros/fuerte/share/turtlesim$ roscore
... logging to /home/irobot/.ros/log/a375ca62-9fcd-11e1-9063-4025c2c905d8/roslaunch-irobot-desktop-16615.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/__init__.py", line 257, in main
    p.start()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/parent.py", line 257, in start
    self._start_infrastructure()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/parent.py", line 215, in _start_infrastructure
    self._start_server()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/parent.py", line 166, in _start_server
    self.server.start()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/server.py", line 368, in start
    code, msg, val = xmlrpclib.ServerProxy(self.uri).get_pid()
  File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1575, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/xmlrpclib.py", line 1264, in request
    return self.single_request(host, handler, request_body, verbose)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1289, in single_request
    self.send_request(h, handler, request_body)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1391, in send_request
    connection.putrequest("POST", handler, skip_accept_encoding=True)
AttributeError: 'NoneType' object has no attribute 'putrequest'

Bellow is a script to import system variables at start up:

#!/bin/sh
source /opt/ros/fuerte/setup.bash
source /usr/share/gazebo-1.0.0/setup.sh
export ROS_ROOT=/opt/ros/fuerte/share/ros
export PATH=$ROS_ROOT/bin:$PATH
export PYTHONPATH=/opt/ros/fuerte/lib/python2.7/dist-packages
export ROS_WORKSPACE=~/ros_workspace
export ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH
export ROS_PARALLEL_JOBS=-j4
export ROS_MASTER_URI=http://localhost:11311
export ROS_HOSTNAME=localhost
echo ROS_MASTER_URI=$ROS_MASTER_UR

Does anyone have any ideas what is wrong? Thanks.

edit retag flag offensive close merge delete

Comments

What OS are you on? Did you install from .debs? Have you tried with just doing "source /opt/ros/fuerte/setup.bash"... you shouldn't need to set the rest of those variables just to get a roscore to start (and things like ROS_ROOT, PYTHONPATH, etc should be configured by /opt/ros/fuerte/setup.bash)

Eric Perko gravatar image Eric Perko  ( 2012-05-17 10:57:38 -0500 )edit

You should not be doing this in a setup script. For anybody who finds this in the future, setting some of these variables may be unsupported and break things. You should be using ROSWS, in general.

mjcarroll gravatar image mjcarroll  ( 2012-05-20 04:52:12 -0500 )edit

I'm using Ubuntu 11.10, installed based on instructions http://www.ros.org/wiki/fuerte/Installation/Ubuntu, all export are done in setup.sh file which loads from .bashrc, . How should I use rosws applied to this problem? I'm about to remove whole ROS installation and install it again.

Roman Burdakov gravatar image Roman Burdakov  ( 2012-05-21 04:14:02 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-06-03 10:41:21 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

It looks like you have a problem inside your xmlrpclib installation. It's implying that connection is of NoneType which is bad. Do you have a nonstandard version of xmlrpclib?

edit flag offensive delete link more
-3

answered 2012-05-17 09:26:29 -0500

ZeroCool gravatar image

updated 2012-05-17 09:31:10 -0500

Have you tried running it in sudo mode?

edit flag offensive delete link more

Comments

Can you run it as sudo? None of tutorials have said to do it, in fact

$ sudo roscore sudo: roscore: command not found

Roman Burdakov gravatar image Roman Burdakov  ( 2012-05-17 10:10:46 -0500 )edit

sudo -s, your password, and then you need to set the variables again (ROS_MASTER_URI, ROS_PACKAGE_PATH, ROS_IP) then run roscore.

ZeroCool gravatar image ZeroCool  ( 2012-05-17 10:37:03 -0500 )edit
2

You should not need to run roscore as sudo on a properly setup installation (e.g. like from sudo apt-get install ros-fuerte-desktop-full).

Eric Perko gravatar image Eric Perko  ( 2012-05-17 10:56:06 -0500 )edit

Didn't help anyway. Same problem as stated above.

Roman Burdakov gravatar image Roman Burdakov  ( 2012-05-21 04:14:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-16 17:23:19 -0500

Seen: 1,626 times

Last updated: Aug 03 '12