Ask Your Question
0

unable to change logging level in rxloggerlevel

asked 2012-05-06 20:19:20 -0600

Roy89 gravatar image

Hi I recently installed fuerte and have been having problems with stopping all the DEBUG logging message from slowing packages such as stage to a crawl. I have tried changing the logging level using rxloggerlevel in rxconsole but this package freezes because it too prints out DEBUG messages. I also tried using the set_logger_level service call for both stage and rxconsole but the it comes back with

calum0@ubuntu:/opt/ros/fuerte/share/rosconsole/cmake$ rosservice call /stageros/set_logger_level stage WARN ERROR: Unable to communicate with service [/stageros/set_logger_level], address [rosrpc://ubuntu:48262]

I tried to follow the direction at http://www.ros.org/wiki/rosconsole to make my own configuration file and set the logging levels that way but this hasn't worked. I set the ROSCONSOLE_CONFIG_FILE environment path variable to a config.pc file containing

log4j.logger.ros.stage=WARN

This might not have worked due to a strange message I'm receiving every time I run roscore.

log4cxx: Could not read configuration file [/opt/ros/fuerte/config/rosconsole.config].

Any help is greatly appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-05-06 23:07:16 -0600

Roy89 gravatar image

I think it may have been something to do with the old version of ros electric messing with my environment variables as I deleted both electric and fuerte and reinstalled fuerte and things seem to be working now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-06 20:19:20 -0600

Seen: 622 times

Last updated: May 06 '12