Ask Your Question
0

Failed to create global_planner/GlobalPlanner

asked 2020-01-02 05:03:22 -0500

nocturnealley gravatar image

Hi, I have this error when trying to create a custom global planner.

[FATAL] [1577962056.484219920, 8.805000000]: Failed to create the test_planner/GlobalPlanner planner, are you sure it is properly registered and that the containing library is built? Exception: MultiLibraryClassLoader: Could not create object of class type test_planner::GlobalPlanner as no factory exists for it. Make sure that the library exists and was explicitly loaded through MultiLibraryClassLoader::loadLibrary()

I've followed the custom tutorial on the ros wiki exactly, and rospack outputs as expected. I'm running move_base in a custom environment, which runs fine with the normal move_base parameters, and with the carrot_planner and global_planner plugins.

<param name="base_global_planner" value="test_planner/GlobalPlanner"/> and other planner plugins - A star plugin and Relaxed a star - I've tried have all outputted the same error.

Does anyone know how to solve the error? Thanks

edit retag flag offensive close merge delete

Comments

Please link to the tutorial you are following.

David Lu gravatar image David Lu  ( 2020-01-02 10:13:38 -0500 )edit

This is the tutorial that I followed. I tried with the param value "global_planner/GlobalPlanner" as in the tutorial (PLUGINLIB_EXPORT_CLASS arguments and plugin description files were changed) but both versions don't work.

nocturnealley gravatar image nocturnealley  ( 2020-01-02 10:28:26 -0500 )edit

Yup, I am. Thanks for your help. I restarted the computer and the error is gone. Not too sure why that is but the planner is working as expected now.

nocturnealley gravatar image nocturnealley  ( 2020-01-05 08:36:28 -0500 )edit

Hi, have you solved this problem? I also meet it:(

cgm666 gravatar image cgm666  ( 2021-03-08 06:23:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-03 09:22:56 -0500

David Lu gravatar image

Are you launching on the same machine with the new package you've created on the path in the window you're launching in? I've found a simple source ~/.bashrc before you launch move_base sometimes solves problems.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-01-02 05:03:22 -0500

Seen: 650 times

Last updated: Jan 02 '20