/hector_gps_calibration catkin_ceres not found

asked 2019-11-27 09:08:21 -0500

yosra gravatar image

updated 2020-03-11 16:09:25 -0500

sloretz gravatar image

Hello, trying to build hector_exploration node in melodic ros version but getting this error

+++ processing catkin package: 'hector_mapping'
-- ==> add_subdirectory(hector_slam/hector_mapping)
-- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
-- Boost version: 1.65.1
-- Found the following Boost libraries:
--   thread
--   signals
--   chrono
--   system
--   date_time
--   atomic
-- hector_mapping: 2 messages, 0 services
-- +++ processing catkin package: 'hector_gps_calibration'
-- ==> add_subdirectory(hector_navigation-catkin/hector_gps_calibration)
-- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
-- Could NOT find ceres_catkin (missing: ceres_catkin_DIR)
-- Could not find the required component 'ceres_catkin'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/melodic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "ceres_catkin" with
  any of the following names:

    ceres_catkinConfig.cmake
    ceres_catkin-config.cmake

  Add the installation prefix of "ceres_catkin" to CMAKE_PREFIX_PATH or set
  "ceres_catkin_DIR" to a directory containing one of the above files.  If
  "ceres_catkin" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  hector_navigation-catkin/hector_gps_calibration/CMakeLists.txt:10 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/robot-altran/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/robot-altran/catkin_ws/build/CMakeFiles/CMakeError.log".
Makefile:1916: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed
edit retag flag offensive close merge delete

Comments

I am having the same issue. Did you figure out how to resolve this problem?

Imani gravatar image Imani  ( 2020-03-11 11:03:30 -0500 )edit

Have you tried adding the ceres_catkinpackage to your workspace ? https://github.com/tu-darmstadt-ros-p...

marguedas gravatar image marguedas  ( 2020-03-11 16:04:21 -0500 )edit

Hi I tried to add the ceres_catkin package but when I go and do catkin_make in my workspace I get this error: Invoking "make -j2 -l2" failed.

Any ideas on this issue? Thanks!

KennyxD gravatar image KennyxD  ( 2020-11-05 14:53:10 -0500 )edit