Ask Your Question
2

libqt_gui_cpp_sip problems on 13.04 [closed]

asked 2013-04-30 05:26:42 -0500

tub gravatar image

updated 2014-01-28 17:16:23 -0500

ngrennan gravatar image

Hi poeple, I use hydro on ubuntu 13.04 (Raring). When trying to start rqt_graph I get this error:

RosPluginProvider.load(qt_gui_cpp/CppPluginProvider) exception raised in __builtin__.__import__(qt_gui_cpp.cpp_plugin_provider, [CppPluginProvider]):
Traceback (most recent call last):
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rqt_gui/ros_plugin_provider.py", line 78, in load
    module = __builtin__.__import__(attributes['module_name'], fromlist=[attributes['class_from_class_type']], level=0)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/qt_gui_cpp/cpp_plugin_provider.py", line 33, in <module>
    from .cpp_binding_helper import qt_gui_cpp
  File "/opt/ros/hydro/lib/python2.7/dist-packages/qt_gui_cpp/cpp_binding_helper.py", line 43, in <module>
    import libqt_gui_cpp_sip
RuntimeError: the sip module implements API v9.0 to v9.2 but the libqt_gui_cpp_sip module requires API v8.1

this error also prevented me from using groovy on the same system (while groovy is not supposed to work on 13.04, the turtle example works though...). I tried installing older versions

::EDIT:: Problem solved:

I accidentally installed hydro using the quantal repository instead of raring: just replace "quantal" with "raring" on http://www.ros.org/wiki/groovy/Installation/Ubuntu (this) page like this:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu quantal main" > /etc/apt/sources.list.d/ros-latest.list'
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by 130s
close date 2013-05-02 09:36:43

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-30 07:24:45 -0500

130s gravatar image

updated 2013-04-30 07:29:18 -0500

I'm not entirely sure what the source of the issue is, but what version of python-sip are you using? I can run rqt_graph without problem on hydro on raring with the following versions:

$ dpkg -p python-sip
Architecture: amd64
Version: 4.14.5-0ubuntu1
$ python --version
Python 2.7.4

Also just as fyi since I don't know how this relates, this stackoverflow page discusses that the API version you use "is a development snapshot" in Dec 2012.

edit flag offensive delete link more

Comments

I solved the Problem: I accidentally installed the hydro-sources from the quantal repository. After reinstallation with sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu raring main" > /etc/apt/sources.list.d/ros-latest.list'

everything works as expected.

tub gravatar image tub  ( 2013-05-01 22:57:33 -0500 )edit

Question Tools

Stats

Asked: 2013-04-30 05:26:42 -0500

Seen: 1,170 times

Last updated: May 01 '13