PointCloud2 doesn't correctly clear obstacles in costmap_2d

asked 2019-11-18 19:28:47 -0500

PG_GrantDare gravatar image


I have a VLP-16 and am looking to do 3d obstacle detection. I implemented a filter to filter the ground rings and now only have remaining what I am happy is an obstacle estimate. I am trying to put this into costmap_2d but get the following results:

image description

This is after an obstacle has passed through the frame. To verify I took a look at the resulting voxel layer:

image description

Despite as you can see the input cloud does not show any points in this area. Can anyone help me to understand this and how to fix it?

Thanks :)



map_type: costmap origin_z: 0.0 z_resolution: 0.2 # The z resolution of the map in meters/cell. z_voxels: 5
# The number of voxels to in each vertical column, the height of the grid is z resolution * z voxels.

obstacle_range: 20 # The default maximum distance from the robot at which an obstacle will be inserted into the cost map in meters. raytrace_range: 20 # The default range in meters at which to raytrace out obstacles from the map using sensor data

# publish_voxel_map: true

footprint: [[1.115, 0.92], [-1.115,
0.92], [-1.115, -0.92], [1.115, -0.92]] footprint_padding: 0.2 inflation_radius: 1.0  # controls how far away the zero cost point is from the obstacle cost_scaling_factor: 0.5
# slope of the cost decay curve with respect to distance from the object. lower makes robot stay further from obstacles footprint_clearing_enabled: true

global_frame: odom robot_base_frame: base_link update_frequency: 10.0 publish_frequency: 5.0 static_map: false rolling_window: true width: 20.0 height: 20.0 resolution: 0.05

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: base_link, data_type: PointCloud2, topic: /out_cloud, marking: true, clearing: true, min_obstacle_height:
edit retag flag offensive close merge delete