Ask Your Question
0

Invisible robot model in Rviz.

asked 2019-11-09 07:27:54 -0600

asbird gravatar image

updated 2019-11-09 09:39:46 -0600

Hello, I'm new to rviz and I encountered a problem while i was trying to run project from this repo . When im working on Gazebo i can see a whole model of the robot but when i try to do the same on Rviz i can see only laser scanner model.

Robot in Gazebo

Robot in Rviz

Full code is available HERE. The only thing I've changed is when i was trying to run for example gazebo i had errors which were saying that something is wrong with mybot.xacro, I've changed the type of point separated values were typed from

 <box size=".4 .2 .1"/>

to

<box size="0.4 0.2 0.1"/>

end everything work fine except the thing i cant see the model in Rviz.

I'm working on Ubuntu 18.05 LTS

edit retag flag offensive close merge delete

Comments

Additionally: please attach your screenshots directly to the question, instead of linking to an off-site image host. That way we keep this post self-contained.

I've given you sufficient karma for that.

gvdhoorn gravatar imagegvdhoorn ( 2019-11-09 09:15:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-09 09:14:29 -0600

gvdhoorn gravatar image

updated 2019-11-09 10:27:58 -0600

I'm not sure, but as you mention your robot model is invisible in RViz, perhaps this is #q272692. Worth checking.


Edit:

was about to say that this doesn't work but then I've typed first source devel/setup.bash and then export LC_NUMERIC="en_US.UTF-8" - finally it worked !

you'll probably want to add that line to your .bashrc to avoid having to retype it every time.

Note that this will change the way your OS represents/encodes/decodes floating point nrs though.

Finally: according to ros/urdfdom_headers/issues/45 - comment the fixed version of urdfdom_headers should finally be released as an update to Ubuntu Bionic.

So you should not need to override LC_NUMERIC any more in the near future -- after installing that update.

edit flag offensive delete link more

Comments

I was about to say that this doesn't work but then I've typed first source devel/setup.bash and then export LC_NUMERIC="en_US.UTF-8" - finally it worked ! Thank you very much @gvdhoorn

asbird gravatar imageasbird ( 2019-11-09 10:03:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-11-09 07:27:54 -0600

Seen: 24 times

Last updated: Nov 09