Ask Your Question
0

Autoware ROSBAG Demo doesn't work as expected

asked 2019-11-01 08:11:00 -0600

scarlet191101 gravatar image

Hi guys, i'm trying to create a ndt_mapping using our bag file, but isn't successful.

First, according to this page (here)

  1. Go to Simulation tab and select arosbag
  2. Click "Play" and click "Pause
  3. Click Computing tab and select ndt_mapping
  4. Click RViz button
  5. Go back to Simulation tab and click Pause to start mapping

And no point cloud is shown in rviz.

I test the ROSBAG Demo according to this page (here)

And no point cloud is shown in rviz, too.

I using ubuntu 18.04/melodic Autoware:1.12 (use source install)

edit retag flag offensive close merge delete

Comments

To visualize using rviz, you should set TFs properly. I guess this is the cause.

Could you try these additional steps?

  1. Click "TF" in Setup tab
    • for /base_link to /velodyne
  2. Click "TF" in Map tab after Referencing tf.launch in sample moriyama data
    • for /world to /map
  3. Re-launch ndt_mapping
    • Just in case

If not resolved, please give us these information.

  1. Results of rosrun tf view_frames (frames.pdf)
  2. ScreenShots of your runtime_manager and rviz
  3. (If any error message is shown in rviz) the error messages
Kenji Miyake gravatar imageKenji Miyake ( 2019-11-02 18:02:07 -0600 )edit

@scarlet191101 Have you solved this problem?

Kenji Miyake gravatar imageKenji Miyake ( 2019-11-08 02:05:55 -0600 )edit

I don’t have much time to try recently.

Click "TF" I have tried, but it is not effective

I don’t know why I often crash when I last tested.

I will test it when I have time.

Thank you~

scarlet191101 gravatar imagescarlet191101 ( 2019-11-08 02:38:24 -0600 )edit

same issue as above. I tried your suggestions but got this error when relaunching MAP.

RLException: while processing /home/<myname>/.autoware/data/tf/tf.launch: Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/home/<myname>/.autoware/data/tf/tf.launch'

answers to your questions above. 1) dot - graphviz version 2.40.1 (20161225.0304)

Detected dot version 2.40 frames.pdf generated I don't know how to attach a file here but here is a cut and paste of the .pdf. It shows world connected to map and base_link connected to velodyne.

Recorded at time: 1427157851.432 world base_link Broadcaster: /world_to_map Average rate: 99.505 Hz Most recent transform: 1573667449.140 ( -146509597.709 sec old) Buffer length: 4.985 sec map Broadcaster: /base_link_to_localizer Average rate: 99.533 Hz Most recent transform: 1573667449.141 ( -146509597.710 sec old) Buffer length: 4.983 sec velodyne

2) don ...(more)

avdev gravatar imageavdev ( 2019-11-13 11:56:53 -0600 )edit

3) Rviz error: TF: No transform from [base_link] to frame [world] No transform from [velodyne] to frame [world] Points Raw: For frame [velodyne]: No transform to fixed frame [world]. TF error: [Lookup would require extrapolation into the past. Requested time 1427157850.433733120 but the earliest data is at time 1573666846.142417109, when looking up transform from frame [velodyne] to frame [world]]

avdev gravatar imageavdev ( 2019-11-13 11:58:59 -0600 )edit

@avdev Thank you for giving the information. If possible, could you upload the data to Google Drive or some online storage services and share the link?

As for the error, I think the cause is you are launching nodes BEFORE starting rosbag play. When we play rosbag, rosparam use_sim_time will be true. We need to launch nodes after that in order to use the simulation time.

Kenji Miyake gravatar imageKenji Miyake ( 2019-11-14 00:39:29 -0600 )edit

Kenji-

Thanks for the feedback.

I tired it again making sure to start the rosbag play before launching the map node. I am not sure how to check the use_sim_time.

Here are the screen shots and .pdf you asked for. https://drive.google.com/drive/folder...

A second problem that I did not mention earlier is that RuntimeManager has screen tearing making it hard to do more than 2 steps. Any ideas there?

avdev gravatar imageavdev ( 2019-11-17 20:43:40 -0600 )edit

also I did not find the tf.launch in sample moriyama data but used this instead for #2 in your suggestions. /home/<username>/autoware.ai/src/autoware/documentation/autoware_quickstart_examples/launch/tf_local.launch

avdev gravatar imageavdev ( 2019-11-17 20:52:26 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-11-25 22:11:41 -0600

Kenji Miyake gravatar image

updated 2019-12-09 08:10:28 -0600

I've recorded my operation and uploaded it to here.

What I did are:

  1. Download files from here
  2. Setup Autoware according to this page
    • If you are using ROS Melodic, I recommend using master version instead of v1.12, or please wait v1.13 which will be released soon
  3. Launch runtime_manager
  4. Play and pause .bag file
  5. Launch tf of velodyne and map
    • It seemed ndt_mapping requires velodyne-tf BEFORE ndt_mapping
  6. Launch ndt_mapping
  7. Launch Rviz
  8. Cancel the pause of .bag file
  9. Velodyne's points can be seen in Rviz
edit flag offensive delete link more

Comments

Thank you,Kenji Miyake.

I have been able to execute it a while ago, and I'm sorry to respond to it until now.

First, I started testing from the bag file.

Encountered rviz crashes, so I changed to a computer to test.

Now it can be successfully executed, and also successfully executed with its own bag file.

I've recorded my operation and uploaded it to here

scarlet191101 gravatar imagescarlet191101 ( 2019-12-03 02:26:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-11-01 08:11:00 -0600

Seen: 79 times

Last updated: Dec 09