Ask Your Question
0

ur modern driver ur5 PolyScope 3.10

asked 2019-11-01 01:17:11 -0600

Victor Wu gravatar image

Just received a UR5 with PolyScope 3.10, tried to connect ROS to it via ur modern driver kinetic-devel and error encountered. Apart from downgrading PolyScope from 3.10 to 3.9.1, is there any other way round it?

edit retag flag offensive close merge delete

Comments

You need to provide much more detail. What error message do you receive? Can you ping the robot from the control PC?

Upgrading PolyScope probably isn't the solution, basically any PolyScope version should work (I think)

AndyZe gravatar imageAndyZe ( 2019-11-01 22:23:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-02 08:55:30 -0600

gvdhoorn gravatar image

updated 2019-11-04 01:47:28 -0600

Please use UniversalRobots/Universal_Robots_ROS_Driver for newer versions of Polyscope on CB3 and e-series controllers.

edit flag offensive delete link more

Comments

Thank you very much for the information which I do not have. That is exactly what I hope for and fortunately I have not downgraded the PolyScope from 3.10 to 3.9.1 yet. I will try it out tomorrow of day after. I will certainly come back to tell everybody and close this if and when it works.

Victor Wu gravatar imageVictor Wu ( 2019-11-03 06:42:35 -0600 )edit

I am just reading about this UR ROS Driver and was very disappointed to find that it does not support velocity based control, which is what the ur modern driver supports!

Victor Wu gravatar imageVictor Wu ( 2019-11-04 01:51:02 -0600 )edit
gvdhoorn gravatar imagegvdhoorn ( 2019-11-04 01:56:09 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-11-01 01:17:11 -0600

Seen: 18 times

Last updated: Nov 04