ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

I have a urdf for a package and that runs correctly in rviz but i wanna the xacro version of urdf

asked 2019-09-21 01:04:42 -0600

tegusg gravatar image

updated 2019-09-23 09:03:17 -0600

more specific i take de urdf and copy and paste on a xacro even i created a xacro.launch for this xacro in specific but when i run this launch i have the mistake as follow

anonymous@anonymous:~/catkin_ws/src$ roslaunch Ensamblaje1 xacro.launch

ERROR: cannot launch node of type [Ensamblaje1/state_publisher_tutorials]: can't locate node [state_publisher_tutorials] in package [Ensamblaje1]

and i dont see the model on rviz

this is the launch

 <?xml version="1.0"?> <launch>
<arg name="model" default="/home/anonymous/catkin_ws/src/Ensamblaje1/urdf/Ensamblaje1.xacro"/>
<arg name="gui" default="False" />
<param name="robot_description" command="$(find xacro)/ $(arg model)" />
<param name="use_gui" value="$(arg gui)"/>
<node name="state_publisher_tutorials" pkg="Ensamblaje1" type="state_publisher_tutorials" />
<node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher" />
<node name="rviz" pkg="rviz" type="rviz" args="-d $(find Ensamblaje1)/urdf.rviz" />


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-09-23 05:44:26 -0600

aPonza gravatar image

The problem seems to be in the launch file itself, maybe with an incorrect $(find ...), could you edit your question and put it in? You can use the 10101 button to format the content. Also you're probably using the robot_state_publisher tutorial instead of the urdf ones, so maybe take a look at those.

edit flag offensive delete link more


i don't now how i can check that,can you help me?

tegusg gravatar image tegusg  ( 2019-09-23 09:01:17 -0600 )edit

The problem should be with

<node name="state_publisher_tutorials" pkg="Ensamblaje1" type="state_publisher_tutorials" />

(as the error message is implying by saying there's no node of type "state_publisher_tutorials" inside the package "Ensamblaje1") which should instead be

<node name="joint_state_publisher"     pkg="joint_state_publisher" type="joint_state_publisher" />

but also you should probably rename the model to Ensamblaje1.urdf.xacro if I remember correctly.

aPonza gravatar image aPonza  ( 2019-09-23 09:30:16 -0600 )edit

Thank you, it works now and it isn't necesary change the name to Ensamblaje1.urdf.xacro.

tegusg gravatar image tegusg  ( 2019-09-23 09:53:05 -0600 )edit

Question Tools

1 follower


Asked: 2019-09-21 01:04:42 -0600

Seen: 104 times

Last updated: Sep 23 '19