ERROR: cannot launch node of type [robot_localization/ekf_localization_node]

asked 2019-09-19 06:59:06 -0500

enthusiast.australia gravatar image

updated 2019-09-28 15:06:27 -0500

Hello. i am trying to work with robot_localization package. I get this error.

 ERROR: cannot launch node of type [robot_localization/ekf_localization_node]: can't locate node [ekf_localization_node] in package [robot_localization]

Update:: Apparently this worked for me...

First try, source /opt/ros/kinetic/setup.bash, then roslaunch robot_localization ekf_template.launch. If it work? If so, then need to catkin clean the workspace, source /opt/ros/kinetic/setup.bash, catkin build workspace, then workspace cd devel then source setup.bash file.

edit retag flag offensive close merge delete

Comments

1

just two things to check:

  1. where does roscd robot_localization bring you?
  2. do you have an unbuilt/unsuccesfully built robot_localizaiton package in the sourced workspace?
mgruhler gravatar imagemgruhler ( 2019-09-20 00:58:54 -0500 )edit

roscd takes me to the path

/opt/ros/kinetic/share/robot_localization/

How can i check whether i have successully built the package or not? When i run catkin cake, it does not show me robot_localization package with other packages. Did i incorrectly installed it?

enthusiast.australia gravatar imageenthusiast.australia ( 2019-09-20 12:56:53 -0500 )edit

How did you install it?

jayess gravatar imagejayess ( 2019-09-22 17:49:23 -0500 )edit

first i try to clone it, but it didn't work. after that i run this commandsudo apt-get install ros-kinetic-robot-localization But still i have this error. Should i reinstall it? If yes, then can you help me how should i do tha?

WHen i tried to clone it, after everything, i did "catkin_make" and i get this error.

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
Could not find a package configuration file provided by
"my_odom_configuration_dep" with any of the following names:

my_odom_configuration_depConfig.cmake
my_odom_configuration_dep-config.cmake

Invoking cmake failed.

What should i do ? i am not very experienced so may be i am missing something. Any help will be appreciated

enthusiast.australia gravatar imageenthusiast.australia ( 2019-09-22 17:53:47 -0500 )edit

roscd takes me to the path /opt/ros/kinetic/share/robot_localization/

If you are taken to this path, either your environment is not properly set up or you actually had an issue during installation. I guess it is the first, and not the second. Please post the output of the following commands in the terminal where you get the cannot launch... error:

  • echo $ROS_PACKAGE_PATH
  • find /opt/ros -name ekf_localization_node

Then, try

source /opt/ros/kinetic/setup.bash
rosrun robot_localization ekf_localization_node

If you don't get the same error as above, the installation is fine and there is a problem with your workspace. Try to remove any left-overs of the cloned robot_localization package (you should do that probably anyways) and see if it works after sourcing your workspace again.

The other error you get points to some problems in your workspace that are related to your packages (especially my_odom_configuration_dep). Please post ...(more)

mgruhler gravatar imagemgruhler ( 2019-09-23 06:50:00 -0500 )edit

when i run the find command, it gives me this error find: ‘ekf_localization_node’: No such file or directory.

but if i run "source /opt/ros/kinetic/setup.bash" and then "roslaunch ekf_template.launch", it runs for one time. I am confused whether i have installed it incorrectly or what.

enthusiast.australia gravatar imageenthusiast.australia ( 2019-09-23 10:48:30 -0500 )edit

@enthusiast.australia there is definitively something wrong with your setup. Or with the find call. Please make sure you really copy the full command and also have the complete name, even missing one letter will result in no match, if you don't append any wildcards. If the launch file starts without problems, there cannot be an issue with the installed package.

To your original question: please try removing all left-overs from the cloned robot_localization repo, delete the build and devel folder in your workspace, and try to compile again.

mgruhler gravatar imagemgruhler ( 2019-09-24 01:13:20 -0500 )edit

i have tried everything but i am still having the original problem. when i try the above described way, i get this running without erroor.

shairi@ubuntu:/opt/ros/kinetic/share/robot_localization$ rosrun robot_localization ekf_localization_node 
[ INFO] [1569514546.025948593]: Waiting for valid clock time...
[ INFO] [1569514546.026111703]: Valid clock time received. Starting node.

So i get it that problem is with my workspace. I deleted my build and devel folders, then istalled the package again, but still having the same isssue. i see something about deleting the workspace and creating new, but i am not sure ho to do that. Also if i do that, will my other packages and data be removed? OR what could be the alternative to use this package and clean my workspace?

enthusiast.australia gravatar imageenthusiast.australia ( 2019-09-26 11:25:30 -0500 )edit