Ask Your Question
0

MoveIt Quickstart in RViz

asked 2019-09-19 05:39:38 -0500

Mr.7th gravatar image

Hello ROS users ^^ I am using MoveIt Tutorial. (https://ros-planning.github.io/moveit...) When I am launching my RViz with (roslaunch panda_moveit_config demo.launch rviz_tutorial:=true), I see an empty world. Until now, everything works well here. But my problem is here!!! When I add MotionPlaning to my Display window, my panda robot arm is stick together and doesn't look like a normal arm! (I have attached screenshots about my arm and a normal arm!). I also used MoveIt Setup Assistant and created my own configurations, (https://ros-planning.github.io/moveit...), but still doesn't work!

Can you help me????!

I am using Ubuntu 18.04 LTS and ROS Melodic.

Here is a screenshot of robot. Please look at it here ---_(https://drive.google.com/file/d/1yjzGr-_QAcJ5wz8ka-g9e_nF_FmKXiuT/view?usp=sharing)

My robot arm should look like this, but it is not! image description

edit retag flag offensive close merge delete

Comments

1

Please attach your screenshot to the post directly. I've given you sufficient karma for that.

gvdhoorn gravatar imagegvdhoorn ( 2019-09-19 07:55:43 -0500 )edit

Have you seen q296438? I remember seeing other related "collapsed links" questions but can't find them.

aPonza gravatar imageaPonza ( 2019-09-23 06:20:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-09-23 04:26:34 -0500

Try to export LC_NUMERIC="en_US.UTF-8" in the terminal before running the launch file.

(See bug rviz/1151 and the currently pending fix in urdfdom/119)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-09-19 05:39:38 -0500

Seen: 22 times

Last updated: Sep 19