Ask Your Question
0

Pointcloud filter is not working

asked 2019-09-10 01:34:21 -0500

S.Yildiz gravatar image

I have a PMD ToF camera and I want to use the statistical outlier removal filter. I did not write my own node for it, instead I am launching the filter like this:

<node pkg="nodelet" type="nodelet" name="pcl_manager" args="manager" output="screen" />
  <node pkg="nodelet" type="nodelet" name="outlier_removal" 
        args="load pcl/StatisticalOutlierRemoval pcl_manager" output="screen" >

        <remap from="~input" to="/royale_camera_driver/point_cloud" />
        <remap from="~output" to="/filtered_points" />



        <param name="~stddev" value="1.0" />
    <param name="~negative" value="true" />
    <param name="~mean_k" value="100" />


  </node>

The weird thing is that every 2 minutes I get an output and with it an error:

[pcl::OrganizedNeighbor::radiusSearch] Input dataset is not from a projective device!
    Residual (MSE) 0.000511, using 1152 valid points

This guy here http://www.pcl-users.org/Definition-o... has the same problem but I do not use any filter

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-09-10 03:16:03 -0500

S.Yildiz gravatar image

So I managed to solve it by myself. I had to filter the pointcloud with the passthrough filter first

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-09-10 01:34:21 -0500

Seen: 20 times

Last updated: Sep 10