Ask Your Question
0

RTABmap error during the SLAM

asked 2019-08-08 03:21:32 -0500

EdwardNur gravatar image

Hi,

I am using RTABmap RGBD slam using the laser scanner. I have a stereo cam and I used rtabmap node to convert the disparity images to depth map so I could use the laser scanner for mapping. During the SLAM, I got this error:

DLT algorithm needs at least 6 points for pose estimation from 3D-2D point correspondences. (expected: 'count >= 6'), where
>     'count' is 5
> must be greater than or equal to
>     '6' is 6

How can I disable the pose estimation from the camera so I won't get this error anymore?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-08-13 13:34:27 -0500

matlabbe gravatar image

Which rtabmap and opencv versions are you using? You could try different PnP flags with Vis/PnPFlags parameter (default 0=iterative, 1=EPNP, 2=P3P). Otherwise, we can also switch to 3D->3D estimation by setting Vis/EstimationType to 0.

Pose estimation from camera is required on loop closure detection to get a relatively good guess for scan matching. Well, if you don't want visual loop closure detection, you can set Kp/MaxFeatures=-1 to avoid extracting visual features (so no motion estimation will be done with the camera).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-08-08 03:21:32 -0500

Seen: 27 times

Last updated: Aug 13