How to add LIDAR to Husky simulator in Gazebo

asked 2019-07-11 14:36:07 -0600

MKKM gravatar image

I am running Husky simulation in Gazebo as outlined here

In husky_empty_world.launch file there is "arg name="laser_enabled" default="true"/"

However, in spawn_husky.launch (which is called in the previous launch file) there is "arg name="laser_enabled" default="$(optenv HUSKY_LMS1XX_ENABLED false)"/"

So my first question is what "optenv" actually does. The second one is how can I get a simulated LIDAR that publishes to some ROS topic?

I am using ROS-kinetic, when launching husky_empty_world.launch I get the following errors:

Warning [] multiple inconsistent <gravity> exists due to fixed joint reduction overwriting previous value [true] with [false].

This setting assumes you have an old package with an old implementation of DefaultRobotHWSim, where the robotNamespace is disregarded and absolute paths are used instead. If you do not want to fix this issue in an old package just set <legacymodens> to true.

and while exiting, I get:

[base_controller_spawner-4] escalating to SIGTERM

[gazebo-2] escalating to SIGTERM

PS. I have tried to follow this tutorial but there seems to be no .sdf file for husky in my installation.

edit retag flag offensive close merge delete