Ask Your Question
0

Robot arm colliding with workcell

asked 2019-07-10 07:48:29 -0500

pathare gravatar image

updated 2019-07-10 08:58:19 -0500

I'm having an issue in my robot cell where the robot is sitting on the edge of a table and the table is outlined by four posts. running the robot to a random location in the center of the table I have about a 50 percent chance of the robot pathing through one of the posts close to it. image description

I've read through some of the moveit docs such as this http://docs.ros.org/melodic/api/movei... and I've tried to play with "longest _valid_segment_fraction" for my planner. I don't know that I've seen any changes though. I've also tried to make the collision tags for each of the posts slightly larger so the sample checker has a higher probability of checking in collision but that hasn't helped either.

I guess my first question is how exactly do I use the "longest _valid_segment_fraction". my assumption was to place it inside the specific motion planner headder like the following.

  RRTConnect:
    type: geometric::RRTConnect
    range: 0.0  # Max motion added to tree.
    longest_valid_segment_fraction: 0.0005

are there any other ways of preventing the collisions?

Thanks

edit retag flag offensive close merge delete

Comments

I've closed your question as it violates the Support Guidelines. Specifically the request to not post screenshots of code/terminals or other kinds of text.

The RViz screenshot is fine, but please replace the screenshot of the .yaml file.

Copy-paste the contents into your question, select all of it and then press the Preformatted Text button (the one with 101010 on it).

You don't need to post a new question: just use the edit button/link to edit it.

gvdhoorn gravatar imagegvdhoorn ( 2019-07-10 08:43:49 -0500 )edit

I fixed it but cant reopen it myself.

pathare gravatar imagepathare ( 2019-07-10 09:04:15 -0500 )edit
1

I guess my first question is how exactly do I use the "longest _valid_segment_fraction"

I would first check your collision geometry.

Does your cell have proper collision geometry specified?

Can you show a screenshot of RViz with the collision geometry enabled?

gvdhoorn gravatar imagegvdhoorn ( 2019-07-10 09:13:51 -0500 )edit

You were right, I forgot that I set an artificial ceiling so I didnt need to make collision objects for the upper rails. in the initial pose the robot was already in collision with the ceiling. I made the top rails like I should have done from the start and it works now.

pathare gravatar imagepathare ( 2019-07-10 12:31:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-10 12:34:32 -0500

pathare gravatar image

I would first check your collision geometry.

Does your cell have proper collision geometry specified?

Can you show a screenshot of RViz with the collision geometry enabled?

This from gvdhoorn was the correct answer to my problem. Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-10 07:48:29 -0500

Seen: 19 times

Last updated: Jul 10