Ask Your Question

Error running the autoware runtime manager

asked 2019-07-07 08:18:24 -0600

udeto gravatar image

updated 2019-07-08 04:34:33 -0600

gvdhoorn gravatar image

I try to run the autoware rosbag demo ( but the autoware runtime manager reports following error after launching it using ./run

top: bad delay interval '0.1'
Exception in thread Thread-8:
Traceback (most recent call last):
  File "/usr/lib/python2.7/", line 801, in __bootstrap_inner
  File "/usr/lib/python2.7/", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/carla/autoware/ros/install/runtime_manager/lib/runtime_manager/", line 1408, in top_cmd_th
    s = subprocess.check_output(['sh', '-c', 'env COLUMNS=512 top -b -n 2 -d 0.1']).strip()
  File "/usr/lib/python2.7/", line 223, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
CalledProcessError: Command '['sh', '-c', 'env COLUMNS=512 top -b -n 2 -d 0.1']' returned non-zero exit status 1

I have installed autoware v1.12.0 from source ( on ubuntu 18.04. with ROS melodic.

The output of locale is:


Can somebody help me with this issue?

edit retag flag offensive close merge delete



This could be a locale issue (commas vs dots). Does top -b -n 2 -d 0,1 in a terminal work?

gvdhoorn gravatar imagegvdhoorn ( 2019-07-07 08:44:29 -0600 )edit

Yes, thank you very much! I just had to replace "0.1" with "0,1" in and it worked.

udeto gravatar imageudeto ( 2019-07-07 10:27:36 -0600 )edit

That is not a solution. It was a step in diagnosing what is wrong.

What is the output of locale?

gvdhoorn gravatar imagegvdhoorn ( 2019-07-07 10:52:46 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-07-08 04:38:36 -0600

gvdhoorn gravatar image

updated 2019-07-08 04:38:50 -0600

The output of locale is:


you have configured a German "regional format" with an English system language.

That in itself is not a problem, but it would appear Autoware -- at least the version you are attempting to use -- assumes a US regional setting (ie: a locale that uses dots to separate decimals instead of commas).

It has hardcoded the use of a dot (.) in the top command line used in the runtime manager.

I would suggest to report this on the Autoware issue trackers, as either Autoware should require the user to use a dot-based regional setting, or Autoware should become locale-agnostic/aware.

edit flag offensive delete link more


If you do report this to the Autoware maintainers/authors, please post a link here to your issue so we can keep things connected.

gvdhoorn gravatar imagegvdhoorn ( 2019-07-08 04:45:58 -0600 )edit

Alright, thank you, for your help!

udeto gravatar imageudeto ( 2019-07-08 06:42:23 -0600 )edit

Could you please mark the question as answered by ticking the checkmark (✓) to the left of the answer if you feel it has been answered? Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2019-07-08 06:43:36 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2019-07-07 08:18:24 -0600

Seen: 138 times

Last updated: Jul 08