Ask Your Question

Revision history [back]

The output of locale is:

...
LC_NUMERIC=de_DE.UTF-8
...

you have configured a German "regional format" with an English system language.

That in itself is not a problem, but it would appear Autoware -- at least the version you are attempting to use -- assumes a US regional setting (ie: a locale that uses dots to separate decimals instead of commas).

It has hardcoded the use of a dot (.) in the top command line used in the runtime manager.

I would suggest to report this on the Autoware issue trackers, as either Autoware should require the user to use a dot-based regional setting, or Autoware should become locale-agnostic/aware.

The output of locale is:

...
LC_NUMERIC=de_DE.UTF-8
...

you have configured a German "regional format" with an English system language.

That in itself is not a problem, but it would appear Autoware -- at least the version you are attempting to use -- assumes a US regional setting (ie: a locale that uses dots to separate decimals instead of commas).

It has hardcoded the use of a dot (.) in the top command line used in the runtime manager.

I would suggest to report this on the Autoware issue trackers, as either Autoware should require the user to use a dot-based regional setting, or Autoware should become locale-agnostic/aware.