Ask Your Question
0

gzserver lookup error from libgazebo_ros_control.so file while using roslaunch

asked 2019-07-05 05:23:22 -0500

microbot gravatar image

Hello,

I am quite new to gazebo and ros, I am trying to launch a gazebo world and spawn a model along with control node using roslaunch. my launch file looks like this :

 <!-- We resume the logic in empty_world.launch, changing only the name of the world to be launched -->
<include file="$(find gazebo_ros)/launch/empty_world.launch">
<arg name="world_name" value="$(find spider_gazebo)/worlds/spider.world"/>
<arg name="debug" value="$(arg debug)" />
<arg name="gui" value="$(arg gui)" />
<arg name="paused" value="$(arg paused)"/>
<arg name="use_sim_time" value="$(arg use_sim_time)"/>
<arg name="headless" value="$(arg headless)"/>
<arg name="verbose" value="true" />
</include>

 <!-- Load the URDF into the ROS Parameter Server -->
<param name="robot_description"
 command="$(find xacro)/xacro.py  --inorder '$(find spider_description)/urdf/spider.xacro' " />

<!-- Run a python script to the send a service call to gazebo_ros to spawn a URDF robot -->
<node name="urdf_spawner" pkg="gazebo_ros" type="spawn_model" respawn="false" output="screen"
  args="-urdf -model spider -param robot_description"/>

 <!-- ros_control spider launch file -->
 <include file="$(find spider_control)/launch/spider_control.launch" />

When i tried to launch this using roslaunch , I can see that status of the spawnmodel is succesfully spawnned the entity. but later when starting the gazrbo_ros_control node for my model, I see that the process is finished cleanly and then I get the error. the error is as follows

  log file: /home/microbot/.ros/log/477e3f36-9f0d-11e9-abc5-2c6e85b13edd/urdf_spawner-4*.log
 gzserver: symbol lookup error: /home/microbot/catkin_ws/devel/lib/libgazebo_ros_control.so: undefined symbol: 
_ZN4urdf5Model10initStringERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE
 [gazebo-2] process has died [pid 11790, exit code 127, cmd /home/microbot/catkin_ws/src/gazebo_ros/scripts/gzserver -- 
 verbose -e ode /home/microbot/catkin_ws/src/spider/spider_gazebo/worlds/spider.world __name:=gazebo 
 __log:=/home/microbot/.ros/log/477e3f36-9f0d-11e9-abc5-2c6e85b13edd/gazebo-2.log].
log file: /home/microbot/.ros/log/477e3f36-9f0d-11e9-abc5-2c6e85b13edd/gazebo-2*.log
[Err] [TransportIface.cc:395] Unable to connect to master.
[Err] [GLWidget.cc:856] Unable to connect to a running Gazebo master.

and then it displayz that preparing world and the gazebo is never loaded and hence I had to shutdown the process with ctrl+c, can anyone please helpme with whats causing this error, i sourced and exported ros environment variables , is the verbose argument causing this ? I am using Ros kinetic and gazebo 7.15

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-11 06:50:12 -0500

microbot gravatar image

I believe I have finally found the answer. I have installed gazebo_ros_pkgs from source and did catkin_make. This gazebo_ros_pkgs is a meta package but it still had tags other than build and executable. I believe the problem is with that package as it has solved when I updated my ubuntu to 18.04 from 16.04 and installed gazebo integrated ros melodic version.

Also the reason behind second error where gazebo was not able to spawn the entity for controller manager is because , there is inertial element for my root link and kdl does not support that. Despite seeing that warning, I did not think it can do much. Also I have made a type when loading a joint_state_controller.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-05 05:23:22 -0500

Seen: 50 times

Last updated: Jul 11