ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to solve problem with PATH_TOLERANCE_VIOLATED in moveit?

asked 2019-06-09 15:55:19 -0600

lbajlo gravatar image

updated 2022-01-22 16:09:58 -0600

Evgeny gravatar image

Hi everyone, I am facing with problem when I want to execute my trajectory in moveit and see it in Gazebo because of error which says:

Controller failed with error PATH_TOLERANCE_VIOLATED

what should I do to solve this error and how to do it? Should I somehow decrease path tolerance maybe? if any other information needs to be provided I will be glade to provide it.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-06-10 09:41:47 -0600

This error is triggered when your (real or simulated) robot is unable to follow the planned trajectory precisely enough. There could be several different root causes of this.

A. The controllers on your robot may not be well tuned, so that the error between their set point and actual position becomes too great. If you've built your own robot in Gazebo this may be likely.

B. The path planner has produced a trajectory which the robot is physically incapable of following. If the speed or acceleration limits of the joints are set unrealistically high then the trajectory will be impossible for the robot to follow.

C. The path tolerance may be set unrealistically fine.

Things to try:

  • Lower the speed and acceleration multipliers in the Moveit GUI (or API if you're using that)
  • Try improving the tuning of your PID controllers if you made the robot yourself.
  • Increase the path tolerance, but make sure your robot is still accurate enough to achieve its task and safely avoid collisions.

Also can describe your robot model in Gazebo, is it a ready made one or have you make it yourself?

edit flag offensive delete link more



Hi Peter,thanks for answer. This part with increasing tolerance was helpful. Sorry for accepting answer so late but I didn't notice that you answered on my question here.

lbajlo gravatar image lbajlo  ( 2020-01-09 08:05:19 -0600 )edit

No problem, glad it helped.

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2020-01-09 15:12:48 -0600 )edit

Hi @PeteBlackerThe3rd and @lbajlo, how can I decrease the tolerance?

Edit: to change the path tolerance, open the controller and next to the joint you'll see {trajectory: __, goal: ___} to change the path tolerance change the trajectory value and goal tolerance with the goal value

ryanc gravatar image ryanc  ( 2020-11-23 12:00:18 -0600 )edit

Question Tools



Asked: 2019-06-09 15:55:19 -0600

Seen: 2,344 times

Last updated: Jun 10 '19