Ask Your Question
4

AttributeError: module 'enum' has no attribute 'IntFlag'

asked 2020-03-20 11:12:50 -0600

Mr.Gao gravatar image

updated 2020-06-18 19:40:04 -0600

lucasw gravatar image

for python3 user, the tutorial suggest to run:

$ catkin_make -DPYTHON_EXECUTABLE=/usr/bin/python3

to build the workspace.

however, following error may come:

AttributeError: module 'enum' has no attribute 'IntFlag'

https://github.com/iterative/dvc/issu...

found one answer from github, it says this error is caused by enum34, which is not support in newer version python3. if you uninstall this module, the error will be solved. but to uninstall enum34, you need to uninstall the melodic ROS also.

can anyone contact the maintainer to help to solve this weird issue???

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-06-18 19:47:35 -0600

lucasw gravatar image

updated 2020-06-18 19:47:47 -0600

In my case (inside a 20.04 docker with noetic) enum34 was installed via pip, and no other packages were depending on it, so this worked:

pip3 uninstall -y enum34
edit flag offensive delete link more
0

answered 2020-04-08 18:25:44 -0600

attackordie gravatar image

Might be that your $PYTHONPATH is set to python2.x

Check the python version with

$ echo $PYTHONPATH

Then try unsetting with

$ unset PYTHONPATH

Now try

$ catkin_make -DPYTHON_EXECUTABLE=/usr/bin/python3

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-03-20 11:12:50 -0600

Seen: 13,106 times

Last updated: Jun 18 '20