Ask Your Question
0

Using setMaxVelocityScalingFactor with fanuc_driver_exp

asked 2019-05-07 14:21:49 -0500

ccetin gravatar image

updated 2019-05-07 17:38:41 -0500

Is it possible to use setMaxVelocityScalingFactor with fanuc_driver_exp ? I have tried to set it to a really low value to see it had any effect but it doesn't seem to work. If that cannot be used, what would be a quick way to limit the maximum velocity?

If it matters, I am trying this on Fanuc lrmate 200ic (v 7.70).

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-08 03:06:13 -0500

gvdhoorn gravatar image

setMaxVelocityScalingFactor(..) is a MoveIt function that influences the eventual time-parameterisation of the path.

It does not directly influence fanuc_driver_exp (or any other robot driver for that matter).

What it does do is change the maximum velocity that should appear in the trajectory that is the result of the time-parameterisation of the path.

Now whether a receiving driver is able to faithfully execute that trajectory is something else entirely, and for fanuc_driver_exp there is even a note in the readme about this (from here):

tries to adhere to commanded velocity constraints on trajectory segments (but will most likely fail)

Having said that, a very slow trajectory should result in slower execution, even if the driver will not be able to actually execute the trajectory completely as it is specified.

If you can provide two wireshark captures of traffic between your ROS pc and the controller (one with a regular trajectory and another when you've used setMaxVelocityScalingFactor(..)) we can see whether at least all the infrastructure on the ROS side is functioning correctly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-07 14:21:49 -0500

Seen: 1,174 times

Last updated: May 08 '19