Ask Your Question
0

Fanuc_driver_exp for robot with roboguide V9.10

asked 2019-04-02 04:03:00 -0500

Kluun gravatar image

updated 2019-04-02 04:05:13 -0500

gvdhoorn gravatar image

Hello,

I am trying to run the fanuc_driver_exp on R30i-B plus controller with Roboguide 9.10, but have no luck with it. I got the fanuc_driver working on the R30i-B plus, by loading the .kl and .ls files Roboguide and compiling the code there (see the link for the steps i took).

There are some limits in the fanuc_drive so i wanted too install the fanuc_driver_exp. I followed the steps on the git and source build the files. Wen i try to copy it on the Fanuc controller (via the teach pendant) i got the message:

Program version is too old

Than i tried to load the .kl and .ls files and compile it like the fanuc_driver instruction, but i could not build it in roboguide.

Can anyone help me to get the fanuc_driver_exp for Robotguide 9.10?

I run ROS kinetic on a ubuntu 16.04 system and run Roboguide on a windows 10 system.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-04-02 04:07:16 -0500

gvdhoorn gravatar image

updated 2019-04-02 04:09:33 -0500

I followed the steps on the git and source build the files.

One of the settings to configure when invoking rossum is the "core version" (ie: the base system software version), using the -c or --core flag:

  -c ID, --core ID      Version of the core files used when translating
                        (default: V7.70-1). Use the 'ROSSUM_CORE_VERSION'
                        environment variable to configure an alternative
                        default without having to specify it on each
                        invocation of rossum

as stated there, the default is to use V7.70-1. For your R-30iB+, that would probably need to be set to V9.10-1.

Could you check you did that?

You can find the currently configured core version in the build.ninja file in the build folder of your rossum workspace (look for the /ver argument to ktransw.cmd near the top of the file (under build rules).

edit flag offensive delete link more

Comments

And of course please make sure you actually need to build from source. There are binary distributions available in the release section of the repository.

gvdhoorn gravatar image gvdhoorn  ( 2019-04-02 04:28:49 -0500 )edit

Thx @gvdhoorn. I changed the /ver number into the build.ninja file and it successfully installed on the controller

Kluun gravatar image Kluun  ( 2019-04-02 04:30:04 -0500 )edit

@Kluun I'm trying to use this driver with my 9.10 version system as well, but unfortunately I do not have a copy of Roboguide. Is it possible for you to provide the files that you made?

qwrtyuiop gravatar image qwrtyuiop  ( 2019-04-03 20:58:33 -0500 )edit

@qwrtyuiop if you give me a email address i can send you the Karel files.

Kluun gravatar image Kluun  ( 2019-04-09 01:11:18 -0500 )edit

Now, I run into the same trouble. It is not possible for my to compile the driver for controller version 9.10-1 by myself due to our company IT restrictions. I get all the time the msg ninja has no access.

So, is there a compiled package out there, now?

nicob gravatar image nicob  ( 2022-04-04 08:30:34 -0500 )edit

due to our company IT restrictions. I get all the time the msg ninja has no access.

all of the used tools are run from user-writable directories. No special permissions are needed. If you have Roboguide installed, the rest is all run from a sub directory of your user's home directory (ie: %USERPROFILE% on Windows). If you don't have access there, something else is wrong.

gvdhoorn gravatar image gvdhoorn  ( 2022-04-04 09:59:50 -0500 )edit

I think it is not a problem with write permissions in the directories. Rossum works perfectly with absolut path specifications to ktransw.cmd, ktrans.exe, etc. It writes also the build.ninja w/o problems.

Unfortunaly I can not provoke more information with the flag -v.

I get the info in various stackoverflow threads, that this problem of ninja is often caused by Windows Defender. And it is not possible for me to deactivate or modify ist. Our company IT support ist not really helpfull to special requests.

nicob gravatar image nicob  ( 2022-04-05 00:39:00 -0500 )edit

Ninja sometimes gets flagged due to a false positive in Windows Defender. That's a problem with a Microsoft product.

Working around that doesn't sound like a special request, but I understand IT departments can be difficult with things that don't align with their typical day-to-day operations.

I'll see if I can build the files for you, but I cannot give you an ETA on when that would be. Perhaps finding a non-corporate laptop/PC with Windows would be faster.

gvdhoorn gravatar image gvdhoorn  ( 2022-04-05 03:43:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-04-02 04:03:00 -0500

Seen: 954 times

Last updated: Apr 02 '19