Ask Your Question
0

Help with Fanuc M-710iC/50

asked 2015-07-30 15:58:17 -0600

Sudarshan gravatar image

updated 2015-07-31 09:05:51 -0600

gvdhoorn gravatar image

Hi,

This is a continuation of the conversation from the github issue of fanuc_driver as per the request of the maintainer. You can find the original conversation here.

Answer to the questions raised by gavanderhoorn there:

Ok, so steps 1 & 2 of Running the ROS-Industrial programs on your Fanuc robot are successful? The robot visualised in RViz shows the same motion as the real one.

Yes. I made sure that the RVIZ was reading the robot states and as I manually moved the robot joints using the pendant, I could see it move on RVIZ.

Is this still with only rosstate running on the robot?

Again: you're only running rosstate at this point?

If you answered yes to all my questions, then you should essentially move to step 3 of the tutorial I linked ("On the TP, start the ros TPE program"). In order for the robot to execute your trajectories, you need to be running the ros TP program. rosstate, as the name implies, only broadcasts joint states, it cannot perform any motion.

Yes. I was only running rostate at that point. After reading your response I ran ros from TPE (which, correct me of I'm wrong, has RUN ROS_STATE, RUN ROS_MOVESM, CALL ROX_RELAY). RIVZ is still able to read the states from the robot but even now sending commands to the robot does not work.

For example, I still get controller takes too long error:

[ INFO] [1438288838.217184191]: ParallelPlan::solve(): Solution found by one or more threads in 0.122578 seconds
[ INFO] [1438288838.217382544]: manipulator[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
[ INFO] [1438288838.217470676]: manipulator[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
[ INFO] [1438288838.232510276]: manipulator[RRTkConfigDefault]: Created 9 states
[ INFO] [1438288838.272224274]: manipulator[RRTkConfigDefault]: Created 37 states
[ INFO] [1438288838.272384298]: ParallelPlan::solve(): Solution found by one or more threads in 0.055077 seconds
[ INFO] [1438288838.274225942]: SimpleSetup: Path simplification took 0.001782 seconds and changed from 3 to 2 states
[ERROR] [1438288841.993446399]: Controller is taking too long to execute trajectory (the expected upper bound for the trajectory execution was 3.708576 seconds). Stopping trajectory.
[ INFO] [1438288841.993557245]: MoveitSimpleControllerManager: Cancelling execution for 
[ INFO] [1438288842.099845429]: ABORTED: Timeout reached

If you can tell me which particular variant of the M-710iC you have, I might have an unreleased support pkg for it.

Let me know if you need any more details about the robot.

I just realized when setting things up, for the TPE Programs section, I just left everything at default. I am referring to this because I didn't know how to edit it using the teach pendant (in particular, I didn't know how to get the colon in 1:ROS-I rdy). I'm not sure if this will cause any problems but thought I should let you know about it.

EDIT

Ok. Please tell me exactly how you setup your workspace, which versions of the packages you installed, what you installed, and what you are trying to run ...

(more)
edit retag flag offensive close merge delete

Comments

@Sudarshan: could you please mark this question as answered?

gvdhoorn gravatar imagegvdhoorn ( 2015-09-04 02:10:30 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-30 16:16:14 -0600

gvdhoorn gravatar image

updated 2015-09-04 02:09:54 -0600

Edit (2015-09-04): this turned out to be user error. Everything was installed and setup correctly, but as the controller was not in auto mode, the operator has to keep the deadman switch, and shift depressed, or else the programs running on the controller will be paused.

Failing to do so resulted in the issues described in this Q/A. An off-list troubleshooting session quickly got to the root cause of the problems described, and everything started to work correctly.


Ok. Please tell me exactly how you setup your workspace, which versions of the packages you installed, what you installed, and what you are trying to run (launch files, etc). Please update your original question with that information.

The manipulator we are using is Fanuc Robot M-710iC/50.

I like the large image you included, but just the model name would've sufficed :). We could be needing all that space for question updates pretty soon.

Yes. I was only running rostate at that point. After reading your response I ran ros from TPE (which, correct me of I'm wrong, has RUN ROS_STATE, RUN ROS_MOVESM, CALL ROX_RELAY).

The ros TPE program does start the programs you mention. Can you add what kind of feedback you get on the TP once you've started the ros program? I'm looking for things like

12345 I RSTA Connected
12345 I RREL Connected

If you don't see that, something is wrong, and trajectory execution will not work no matter what you try.

RIVZ is still able to read the states from the robot but even now sending commands to the robot does not work.

I'm just going to include this for completeness, but do know that if your controller is not in AUTO mode, you'll have to keep pressing SHIFT + keep the deadman depressed for trajectory execution to work.

[..] I still get controller takes too long error:

With the way the current driver works, you'll always get that error (we cannot get 100% performance out of the controller), so I'd advise you to either allow way more time for execution (use the scaling factor) or disable the execution monitoring completely. See the fanuc_driver/Troubleshooting - Robot stops at seemingly random points during trajectory execution section for info on how to that (the linked ROS Answers post has an example that shows how to edit your launch files).

I just realized when setting things up, for the TPE Programs section, I just left everything at default. I am referring to this because I didn't know how to edit it using the teach pendant

You'll want to make sure that none of the used flags, integer or position registers is used by other programs on the controller. If the fanuc_driver Karel and TP programs are the only one running on the controller, the defaults are probably free to use.

(in particular, I didn't know how to get the colon in 1:ROS-I rdy). I'm not sure if this ...

(more)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-30 15:58:17 -0600

Seen: 700 times

Last updated: Sep 04 '15