Ask Your Question
0

lrmate200ic automode

asked 2016-02-12 04:58:49 -0500

alex_wwa gravatar image

updated 2016-02-12 06:10:03 -0500

gvdhoorn gravatar image

Please, help me,

I work with fanuc lrmate200ic (V7.7 with R648 and R632) and ROS Hydro. I have done basic configuration. I began to test steering of an indstrial robot but the robot executes commands only under the T1 mode. When I switch the robot in auto mode and run a ros TPE program i see only

I RREL Waiting for ROS traj relay

message and when i run command

roslaunch fanuc_lrmate200ic_moveit_config moveit_planning_execution.launch sim:=false robot_ip:=IP_OF_ROBOT

on PC, TP displays message Connected. But, further communication is not possible.

edit retag flag offensive close merge delete

Comments

Running the fanuc_driver Karel & TP programs in AUTO mode is definitely possible. Can you check the robot's error log, and please update your question (use the edit button/link) with the exact steps you take to start the ros TPE program (ie: programs selected, buttons pressed, etc).

gvdhoorn gravatar image gvdhoorn  ( 2016-02-12 06:08:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-12 06:58:49 -0500

alex_wwa gravatar image

Thank you very much, you were right, error was in the process. It was necessary to enter into the ros TPE program and after that press cycle start on control panel. Thanks for your time.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-12 04:58:49 -0500

Seen: 120 times

Last updated: Feb 12 '16