Connecting SICK MRS1000 with ubuntu (kinetic)

asked 2019-04-02 03:38:15 -0500

ekii gravatar image

updated 2019-04-02 03:41:58 -0500

gvdhoorn gravatar image

Hello, Im new with ROS and im sorry if my question lack required information. So I'm trying to connect Sick mrs1000 lidar to Ubuntu 16.04(Xenial). Lidar works fine with Windows SOPAS but if I try to connect over local network or straight connection with RPI 3b+. I have faced couple of different problems but what im facing now I can't figure out a way to go around it. Problem looks like:

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /sick_mrs1000/device_number: 0
 * /sick_mrs1000/filter_echos: 0
 * /sick_mrs1000/frame_id: laser
 * /sick_mrs1000/hostname: 10.67.10.130
 * /sick_mrs1000/intensity: True
 * /sick_mrs1000/max_ang: 0.785398163
 * /sick_mrs1000/min_ang: -0.785398163
 * /sick_mrs1000/port: 2111
 * /sick_mrs1000/publish_datagram: True
 * /sick_mrs1000/range_max: 64.0
 * /sick_mrs1000/range_min: 0.2
 * /sick_mrs1000/skip: 0
 * /sick_mrs1000/subscribe_datagram: True
 * /sick_mrs1000/time_increment: 6.1722e-05
 * /sick_mrs1000/time_offset: -0.001

NODES
  /
    sick_mrs1000 (sick_tim/sick_mrs1000)

ROS_MASTER_URI=http://localhost:11311

process[sick_mrs1000-1]: started with pid [7155]
[ INFO] [1553866265.930132579]: Waiting 5 seconds for device to connect.
[ INFO] [1553866265.931225588]: Succesfully connected to 10.67.10.130:2111
[ WARN] [1553866265.948110865]: Dropping 14499 bytes to avoid buffer overflow
[ INFO] [1553866265.948905231]: active application reply: sSN LMDscandata 1 1 108E48D 0 0 BF59 BF59 CF352C96 CF362B3A 0 0 E0 0 FE0C 1388 B4 0 3 DIST1 3F800000 00000000 FFFAA8D0 9C4 3E9 7D 7E 7E 7E 82 83 84 85 87 86 7F 80 86 87 8B 8D 8C 89 8A 8C 8A 8D 8C 8F 97 92 8C 8F 8F 8F 95 97 94 93 96 96 9A 99 9A 9E 99 9B A0 A1 9F 9E A1 A3 A5 A2 9E A1 A6 A9 AB B0 AF A7 A6 AA AE AE AF AF AC A7 A3 A4 A4 AB B3 B4 B6 B7 B9 BF CC D3 CE CA C7 C6 C6 C1 B9 B4 B6 B7 BE C3 C5 C3 BE BC BB C0 C7 C8 C3 C0 C2 C5 C7 BE B9 BF BD AE A7 BA BC BA 249 0 0 353 34E 352 356 354 358 35E 362 367 36B 372 378 377 37A 382 386 38C 392 393 395 39F 3A7 3AA 3AD 3B0 3B3 3B9 3C1 0 0 0 0 0 0 0 319 0 0 0 A7 A7 A6 A4 A6 A8 AA A9 A5 9F A0 44B 44F 458 461 466 46A 471 47C 486 48D 492 498 4A1 4A9 4B0 4B5 4BB 4C9 4D5 4DD 4E4 4ED 4F8 502 50C 516 521 528 532 538 532 52E 524 523 524 51B 517 513 514 534 57C 5BC 5E7 608 616 60F 605 5F1 5D3 5C3 5AF 5A0 598 590 58F 58A 57B 572 568 55C 530 4C8 492 489 48C 495 49D 49F 49E 49D 49E 4A1 4A5 4AA 4AA 4A9 4AF 4B2 4B5 4BB 4C3 4C9 4CF 4D3 4D7 4DC 4E6 4F3 4F4 4F
[ WARN] [1553866265.950097145]: received less fields than minimum fields (actual: 3, minimum: 32), ignoring scan
[ WARN] [1553866265.950390579]: are you using the correct node? (124 --> sick_tim310_1130000m01, > 33 --> sick_tim551_2050001, 580 --> sick_tim310s01, 592 ...
(more)
edit retag flag offensive close merge delete

Comments

I'm not familiar with this node, but I've worked with an MRS1000 before. From my experience, it is crucial that you set up the scanner correctly using the Sick Application such that the respective drivers work properly. So can you check that you actually activated the RSSi output? Check the wiki for how to do that, if unsure.

mgruhler gravatar imagemgruhler ( 2019-04-03 00:45:15 -0500 )edit