ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

How to change a planner's timeout?

asked 2019-03-28 07:31:09 -0500

bgd gravatar image

updated 2021-12-03 09:51:50 -0500

Evgeny gravatar image

I'm trying to change the planner's timeout from the default value. I've looked in the config yaml files, launch files etc, searched online, but couldn't find anything, does anyone have any ideas? "The timeout for planning must be positive (0.000000 specified). Assuming one second instead."

edit retag flag offensive close merge delete

Comments

1

Which planner? In which context?

gvdhoorn gravatar image gvdhoorn  ( 2019-03-28 07:32:20 -0500 )edit

I'm using a pathplanning pipeline (it's OMPL but I haven't been able to change the specific algorithm it uses, so it defaults to RRTConnect) and making a planning_interface::MotionPlanRequest . I would like to know if it's possible to change the planning time similar to how Rviz does planning., but in C++.

bgd gravatar image bgd  ( 2019-03-28 08:39:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-03-28 08:53:43 -0500

Still not quite sure what context your working in, but http://docs.ros.org/melodic/api/movei... has an allowed_planning_time field (as well as the planner_id field to change the planning algorithm). You can also use the MoveGroupInterface, which has a setPlanningTime method.

edit flag offensive delete link more

Comments

Perfect! thanks a lot, this is exactly what I was after.

bgd gravatar image bgd  ( 2019-03-28 09:00:32 -0500 )edit

Really i was searching for this left and right. Thnx

kgpton gravatar image kgpton  ( 2021-10-26 12:09:17 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2019-03-28 07:31:09 -0500

Seen: 1,578 times

Last updated: Mar 28 '19