Ask Your Question
0

IIWA giving position but not moving

asked 2019-03-19 09:01:37 -0600

pathare gravatar image

updated 2019-03-19 09:04:55 -0600

I'm trying to work though a demo provided by ROS-I and get my IIWA moving. for reference this is the demo with instructions I'm referring to https://industrial-training-master.re... .

I have read through both versions of the wiki https://github.com/IFL-CAMP/iiwa_stac... and https://bitbucket.org/khansari/iiwa/w... .

My current issue is that I can launch the ROS node on the IIWA and it seems to run attached is an image of what the teach pendent shows when the ROS node is running.

I run the ROS master side with simulated sensors and a real robot. it connects and the simulation gets the current starting position of my robot but once the planning is done and I tell it to execute on the hardware nothing happens.

in the wiki there is a FAQ that mentions robot sending position but not moving is a networking issue. I went and checked the locations that it suggested looking into and it still isn't working. the other thing is that I originally used IP addresses for the koni net and my ros master of 192.168.1.100 and 192.168.1.120 but I remembered seeing something in the kuka manual about invalid IP addresses so I changed these to the addresses that the tutorial says they use of 160.69.69.69 and 160.69.69.100.

I'm still really new to ros so there may be troubleshooting tools available that I'm not aware of. let me know if there is anything specific I'm not including here.image description/WidKQxkFfskM6dFj6)

I dont think i'm adding an image correctly. I think this link will take you to my teach pendent image. https://photos.app.goo.gl/WidKQxkFfsk...

edit retag flag offensive close merge delete

Comments

this is not an answer, but:

so I changed these to the addresses that the tutorial says they use of 160.69.69.69 and 160.69.69.100

unless your company/organisation is allowed to use the 160.69.69.x range, I wouldn't do that. Those addresses are routable IP addresses and that is never a good idea if you don't actually belong to a network that is part of that range. The 192.168.x.x range that you were using before would be better.

Refer to wikipedia/Private network for some more info on this.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-19 09:06:41 -0600 )edit

Thanks for your answer and I can change it back but, I didnt think that type of thing would matter being off an actual network but I'll implement your suggestion.

Thanks

pathare gravatar image pathare  ( 2019-03-19 09:11:48 -0600 )edit

@gvdhoorn That's part of the iiwa_stack setup. IIRC the original IP of the robot controller is on the same IP range, so this shouldn't be more harmful than the factory settings.

fvd gravatar image fvd  ( 2019-03-20 06:58:21 -0600 )edit

@fvd: I don't really understand what you're saying. My comment was about using the 160.x.x.x range of addresses. That range is registered to PACCAR, Inc., not Siemens, so the OP should not use it. It's used in the ROS-I Training Exercises that the OP quotes/refers to.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-20 07:19:19 -0600 )edit

The IP in the 160.x.x.x range is proposed in the setup instructions of the iiwa_stack packages the OP linked: https://github.com/IFL-CAMP/iiwa_stac...

I also dimly remember reading (as the OP mentions) that the KUKA controller blocks connections on other IP ranges. I'm not sure this is a problem here, since those addresses should only be used locally anyway.

fvd gravatar image fvd  ( 2019-03-20 07:33:19 -0600 )edit

Doesn't matter who uses it as an example, it's a public, routable IP and it should not be used by anyone other than the person with hosts in a network that is registered to use it.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-20 07:36:40 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-20 07:10:17 -0600

fvd gravatar image

I assume that you're using iiwa_stack. We had this kind of error frequently, but from what I remember it was always due to some issue with our network settings. Try this:

1) Check the environment variables 'ROS_HOSTNAME' and 'ROS_MASTER_URI'. If you only use one machine, 'ROS_IP' may be used instead of 'ROS_HOSTNAME'.

2) If you use 'ROS_HOSTNAME', make sure your machine and the controller have an entry in '/etc/hosts', and '/etc/hostname' matches.

3) Check the network settings in the KUKA Sunrise Workbench. Does the IP match your machine?

4) Any firewalls? Do you have the right network selected? Are all the cables in the right places?

In general, do a sanity check on all the network connections and settings, and try to ask people with a good grasp on networking. That's the most likely cause of the error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-19 09:01:37 -0600

Seen: 153 times

Last updated: Mar 20 '19